Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Launching error (libxml2.2.dylib version)
09-19-2012, 02:39 PM
Post: #1
Launching error (libxml2.2.dylib version)
Hello,

I've downloaded Vdrift 2012-07-22 for Mac from vdrift.net, but I can't launch the application on my computer. Here's the error message:

Quote:Dyld Error Message:
Library not loaded: /usr/lib/libxml2.2.dylib
Referenced from: / Applications/Vdrift.app/Contents/MacOS/../Frameworks/Archive.framework/Versions/3.0/Archive
Reason: Incompatible library version: Archive requires version 10.0.0 or later, but libxml2.2.dylib provides version 9.0.0

I'm using Mac OS X 10.5.6 and I've had no trouble so far to run VDrift 2010-06-30 (stable), 2011-01-25 (dev) and 2011-07-26 (dev).

Any idea on how I could play the current version ?
Find all posts by this user
Quote this message in a reply
09-19-2012, 03:28 PM
Post: #2
RE: Launching error (libxml2.2.dylib version)
That's what happens when you don't test on old systems Sad Archive.framework needs rebuilding with libxml included, instead of using the user's version, which in this case is an old one and not compatible. I'll try and upload a new version as soon as possible (probably at the weekend), but if you want to play sooner, update to a newer version of OS X, or update libxml (via http://macports.org perhaps?).
Visit this user's website Find all posts by this user
Quote this message in a reply
09-20-2012, 12:27 PM
Post: #3
RE: Launching error (libxml2.2.dylib version)
Thank you very much for your quick answer and support!

I think I'll be patient and wait for the next version, upgrading a library is quite an adventure for me, since I have no experience in programming... Blush

Anyway, if you are able to download a new version this weekend, it's still very quick. And this way, I'll test for you the new installation on my old system. Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)