Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFB not working with MOMO wheel (solved)
06-23-2008, 11:52 AM,
FFB not working with MOMO wheel (solved)
I have a strange problem with a MOMO wheel and VDrift 20070323 on a linux box. The wheel works but FFB does not. I can even test FFB with ffcfstress and then the wheel responds correctly on /dev/input/event4. I used to run vdrift as a user and in Gentoo, the permissions for event4 are root:root, so that did not work. But even when I switch the permission for event4 to media:users, which makes ffcfstress work, FFB is not enabled in Vdrift. Any clue?

Thanks in advance, VDrift is great.
06-25-2008, 10:46 AM,
Update to my own post
In the above link, someone suggests that the packaged version on Mandriva didn't have FF either. He used the .autopackage version instead. So there might be some compile option that needs to be specified to enable Force Feedback? If so, which one? I I knew that, I could adapt the .ebuild to include it.

I prefer to have an ebuild version of the game, as the .autopackage format is not supported on Gentoo.
06-25-2008, 10:59 AM,
yes, there is such an option
Answer to my own question:
yes there is an option passed to scons that enables force_feedback. The default is 0. So that's the explanation. I've now updated the ebuild and will try whether it works with force_feedback=1

EDIT: this works. I'll submit a bug report to Gentoo to get ff enabled by default.

Forum Jump:

Users browsing this thread: 1 Guest(s)