Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problem, some help please guys!
02-02-2008, 02:39 PM,
#1
problem, some help please guys!
Hello first post here! im having problems getting vdrift to work on my computer...im running vista ultimate and had to fix the SDL_gfx.dll error. now it starts but just dissapears automatically from my screen for some reason. Anyone got asolution tot his?

thnx!

SiMoNsKy
Reply
02-02-2008, 07:58 PM,
#2
 
Welcome! It sounds like VDrift is crashing on you. I'm not sure if it would work on Vista, as that version was not tested on Vista much. We have a new version out now, but no Windows build for it, so to use it you would have to compile it yourself. It might fix several problems, however.

By the way, what kind of computer/video card do you have, and what drivers are you using for your video card?
Reply
02-28-2008, 02:53 PM,
#3
 
i think i have the same problems, vdrift crashing on me.

i got these errors on stdout after it crashes,

Warning: option-47 is missing its default value. Assuming "".
Run with -verbose for troubleshooting.
Run with -nosound to disable sound.
Run with -benchmark to play a replay and output benchmark data.
0 joystick(s) found:
Extension not supported: GL_ARB_multisample
Extension not supported: GL_EXT_texture_filter_anisotropic
Extension not supported: GL_ARB_texture_cube_map
Extension not supported: GL_ARB_fragment_program
Extension not supported: GL_ARB_multitexture
Extension not supported: GL_ARB_texture_rectangle
Extension not supported: GL_ARB_depth_texture
Extension not supported: GL_ARB_shadow
Extension not supported: GL_EXT_framebuffer_object
main, WIN32: wglGetProcAddress("glMultiTexCoord4fARB") failed.
main, WIN32: wglGetProcAddress("glMultiTexCoord2fARB") failed.
main, WIN32: wglGetProcAddress("glActiveTextureARB") failed.
main, WIN32: wglGetProcAddress("glClientActiveTextureARB") failed.

and this also on stderr

Card supports: drawbuf6789532 auxbuf0
Card does not support: antialiasing anisotropy cubemapping shaders multitexturing texture_rectangle depth_texture shadow framebuffer_objects
Status: Using GLEW 1.4.0
OpenGL error during graphics init

maybe you could explain. for your info, i'm using ATI Radeon express 1100.

thanks before
Reply
02-28-2008, 03:01 PM,
#4
 
Hi, and welcome. Smile

I'm afraid it looks as if your card won't work for VDrift. VDrift requires that your card has multitexturing capabilities, which it seems to lack. You can see this in the line
Ramdhan Wrote:Card does not support: ... multitexturing ...
VDrift is looking for the address of these functions with the calls to wglGetProcAddress that failed.

Sorry I don't have a solution for you. Sad Is this a built in card on a laptop or something? That makes it difficult or impossible to upgrade your card. Perhaps you have another machine you could run VDrift on?
Reply
03-20-2008, 04:27 PM,
#5
 
FYI V-drift crashes on me too, Intel 915GM chipset (laptop). Shame, no v-drift for me?!
Reply
03-21-2008, 12:26 AM,
#6
 
Unfortunately, although VDrift will run on any NVIDIA Geforce card from the 2/3/4/5/6/7/8/9 series (or equivalent ATI card), many built-in 3d cards (especially those from intel) generally don't have enough capabilities. :-(
Reply
05-06-2008, 06:48 AM,
#7
 
I have ATI Radeon 9250 and VDrift not work on this card :cry: . Can you do something to VDrift work on this and other cards?
Reply
05-06-2008, 10:41 PM,
#8
 
You could try turning off shaders. Open up your VDrift.config file and set shaders=off in the [display] section.
Reply
05-07-2008, 07:47 AM,
#9
 
I find the VDrift.config file but i cannot find where is shaders [ main ]
version = 2006-10-06

[ game ]
game_mode = 0
camera_mode = 3
selected_car = TL
car_paint = 0
track = zandvoort
record = off
ghost = off
num_shots = 0
antilock = off
traction_control = on

[ network ]
host_game = 1
server_port = 1234
server_ip = 127.0.0.1

[ display ]
width = 800
height = 600
depth = 16
texture_size = medium
show_hud = on
show_fps = off
mph = on
view_distance = 2500.000000
fullscreen = off
anisotropic = 0
antialiasing = 0
input_graph = off
car_shadows = on
skin = simple

[ sound ]
volume = 0.750000
music_volume = 0.42

[ mouse ]
xsens = 1.000000
ydead = 0.200000
ysens = 0.900000
enabled = 0

[ control ]
autoclutch = off
profile = joystick
button_ramp = 0.0

[ joystick ]
type = joystick
touchcomp = off
deadzone = off
calibrated = off
selected_index = 0

Can someone help me? Sorry, i don't know where is Shaders :?
Reply
05-07-2008, 11:33 AM,
#10
 
Just add the line shaders=off anywhere under the [display] section.
Reply
05-07-2008, 01:14 PM,
#11
 
Ok i fix it but now SDL_gfx.dll missing. Maybe it isn't in install pack?
Reply
05-08-2008, 09:45 AM,
#12
 
Can someone please upload on http://www.zippyshare.com SDL_gfx.dl file before it's missing on install pack.
Reply
05-08-2008, 03:27 PM,
#13
 
I think you're using a really old version, what package did you download? Try out the release candidate for Windows.
Reply
05-11-2008, 07:36 AM,
#14
 
Yeah VDrift run, but id dissapears when i click Play... I download and install Relase Candidate for Windows and something wrong. Please HELP!
Reply
05-12-2008, 09:05 PM,
#15
 
Delete the folder that contains the VDrift.config file, then try VDrift again. VDrift should recreate the folder. If the game still doesn't work, try setting shaders=off in the [display] section of your VDrift.config file.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)