Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
08-25-2007, 09:38 AM,
r1821 compile failed
Tried to compile r1821 but failed because the *.0.dylib doesnt't exists.

Tried to replace in the Other linked flags by -weak_library /usr/local/lib/libvorbisfile.a -weak_library /usr/local/lib/libvorbis.a -weak_library /usr/local/lib/libogg.a, it compile well but when executing the app, the window automatically closes.

The architecture set by cotharyus is i386 for all the projects/target.
08-25-2007, 09:44 AM,
This may be related to the previous post, indicating that my fix works fine where these libs are installed locally, however we should develop frameworks for these. I'm currently trying to overcome some jackassery with building a universal libvorbis framework, at which point we'll be able to build universal binarys that won't fail like this. If you really want to build this SVN, download, build, and install libogg and libvorbis on your mac.
08-25-2007, 09:54 AM,
I had already downloaded the sources of both libraries, compiled and installed them. The versions i use are:
-libogg 1.1.3
-libvorbis 1.2.0
and i just followed the indicated steps to compile.

Hope this can help youSmile
08-25-2007, 10:40 AM,
Ok, here's the current update on OS X. I've built a universal framework of both libogg and libvorbis. I've placed the frameworks with the rest of the frameworks in vdrift/tools/osx, added the necessary header indicators, and everything compiles, but we're back to the old linking problem:

/usr/bin/ld: Undefined symbols:
/Projects/build/ reference to undefined _ov_clear
/Projects/build/ reference to undefined _ov_info
/Projects/build/ reference to undefined _ov_open
/Projects/build/ reference to undefined _ov_pcm_total
/Projects/build/ reference to undefined _ov_read

Anyone care to take a stab at why it's apparently not finding the contents of the Vorbis.framework?
08-25-2007, 11:02 AM,
ogg/vorbis framework
I did the following stuff as you did:
-compiled both frameworks liboggg and libvorbis (but only for i386) using the xcode project furnished with the distribution.
-copied the generated framework folders intto the project structure.
-deleted the Other linked flags
-still kept i386 architecture.

It compile well, and link well and build dmg well, but there is still the crash at startup.

Arghhhh, we are near, and this way is cleaner, where is the problem ?

1-May be we do not compile correctly the libogg and libvorbis file, before include them in the vdrift structure ?

2-The ogg/vobis framework doesn't appear in the 'copy files' of the project, neither in the sconscript.

3-The architecture problem is curious...
08-25-2007, 11:20 AM,
I recompiled ogg/vorbis with i386 and ppc architecure and copied them in the vdrift osx folder structure.

I put i386 ppc archtitecture on the vdrift project Smile

Project sitll compile/link and this time it made a universal binary app Smile

I also put the generated ogg/vorbis frameworks in my /Librairies folder.

But the window still crashes Sad
08-25-2007, 11:29 AM,
Make sure you're trying the laguna seca track, because some other tracks will crash when you load them due to other errors.
08-25-2007, 11:53 AM,
FX - interesting. I've removed the linking flags, built ogg and vorbis libs as universals, placed the frameworks produced in my /Library as well as the vdrift/tools/osx directory, changed over to build for both architectures - and I'm getting the linking errors indicated above.
08-25-2007, 03:38 PM,
cotharyus - I think we have the same configuration actually so it woul also link for you. Try to make a Build->Clean All, say delete references and precompiled headers. It's a thing i have always done since i try to compile vdrift Smile

joe - If i could only choose a track, be sure i would follow religiously your advice. But the application doesn't even start.

I tried to run the Debug mode and Ohhhhhhh the surprise : it seems some files are missing in the current data tarball as said in the log.

May be it would be better to delete Preferences file, or making them dependant of the version running.

I didn't found them either in the official data folder.

Here is the log.

[Session started at 2007-08-25 21:20:17 +0200.]
Found config file /Users/Fx/Library/Preferences/VDrift/controls.
Found config file /Users/Fx/Library/Preferences/VDrift/VDrift.config.
Version of game: 2007-08-25
Skin name not found in config file...
Directory /Users/Fx/Documents/svn/vdrift/tools/osx/build/Debug/data/skins/SConscript/menus does not exist! Skin SConscript not loaded.
Warning: option-47 is missing its default value. Assuming "".
Run with -verbose for troubleshooting.
Run with -nosound to disable sound.
Run with -benchmark to play a replay and output benchmark data.
1 joystick(s) found:
0. Logitech® Precision™ Gamepad
Extension not supported: GL_ARB_multisample
Card supports: drawbuf1 auxbuf0 anisotropy4 cubemapping shaders multitexturing16 texture_rectangle depth_texture shadow framebuffer_objects
Card does not support: antialiasing
Status: Using GLEW 1.4.0
Fragment shaders enabled
EXCEPTION: /Users/Fx/Documents/svn/vdrift/tools/osx/../../src/shader.cpp, line 186: Shader file not found: /Users/Fx/Documents/svn/vdrift/tools/osx/build/Debug/data/shaders/simple/vertex.glsl

vdrift has exited with status 0.
08-25-2007, 03:44 PM,
FX - I clean before I build every time. Completely. It's the only way I've ever done things, it just makes it easier to know when you really have it.
08-25-2007, 05:35 PM,
Mac OS X r1821 successfully built - Bugs detected.
In order to work i had to use the data folder used by cotharius in the r1816 release.

The problem was a OS X file .DS_Store found valid in UTILITY::GetFolderIndex(string folderpath, list <string> & outputfolderlist).

This file shouldn't be there but it was, so i had the test :
if (newname != "." && newname != ".." && newname != ".DS_Store")

Also, the data folder didn't contain the vertex.gsl file, found (thanks again cotharyus) in the r1816 given by cotharyus.

The way cotharyus found to include the libvorbis/ogg framework in the project is good and clean. i hope it will be included in a next release.

Is there an svn to load the data project ?
08-25-2007, 08:16 PM,
Fx: see this wiki page:

For instructions on getting the data.
08-25-2007, 08:52 PM,
FX - I'm still having a problem here. Please, do me a favor and email me your xcode.project file for vdrift - I want to see how it compares to mine since it sounds like they should be the same. Please use the email address cotharyus at gmail dot com
08-26-2007, 04:22 AM,
cotharius - Ok let's go. i send you the project.pbxproj file. This morning as i waked up and thing about this : i removed also the library search path you have added : /usr/local/lib/**

joevenzon - i try to enter the address in the soft i use to get svn (svnx Smile ) it doesn't understand the protocol.
08-26-2007, 12:34 PM,
Fx Wrote:i try to enter the address in the soft i use to get svn (svnx Smile ) it doesn't understand the protocol.

That's weird. Try just entering or just -- I'm not sure how your svnx software works, but rest assured the sourceforge svn is up and working.

Forum Jump:

Users browsing this thread: 1 Guest(s)