Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
scons doesn't work
07-11-2007, 11:54 AM,
i have done it but anyway it doesn't works. In the stdout.txt there's:
Directory data/skins/SConscript/menus does not exist! Skin SConscript not loaded.
Warning: option-47 is missing its default value. Assuming "".
Run with -verbose for troubleshooting.
Run with -nosound to disable sound.
Run with -benchmark to play a replay and output benchmark data.
0 joystick(s) found:
Extension not supported: GL_ARB_texture_rectangle
Status: Using GLEW 1.4.0
07-11-2007, 01:11 PM,
Is that it? Even on VMWare I think mine got a little bit further. Could you also post the stderr.txt?
07-11-2007, 01:24 PM,
In the stderr there's:
Card supports: drawbuf4 auxbuf0 multitexturing8 antialiasing anisotropy16 cubemapping shaders depth_texture shadow
Card does not support: texture_rectangle
Fragment shaders enabled
EXCEPTION: src\shader.cpp, line 180:  Shader file not found: data/shaders/simple/vertex.glsl
07-11-2007, 01:54 PM,
So is the file it's looking for there or not? You will need data from SVN, not the data package from the last release. There have been changes since then (like addition of shader files). See this page which has a big yellow note box explaining how to check out the data repository.
07-13-2007, 09:30 AM,
I have downloaded it and now it's ok, the game start normally. Smile
However there are some bugs:
1) In the part of the menu where is possible to select the car and the race is impossible to see the picture the car.
2) During the game,i have touched the guard rail and the car go out the track and start to rotate.
07-13-2007, 10:09 AM,
Note that both bugs are tracked here;

I'm using that forum page as an issue tracker.
07-14-2007, 05:34 AM,
I have tried to download another time the source from svn but when i try to compile scons tell me:

scons: Reading SConscript files ...

scons: ***AttributeError ''str' object has no attribute 'exe'' trying to evaluate '$EXECUTABLE_NAME.exe'
File "E:\src\src\SConscript", line 123, in <module>

What is the problem? If i try to compile the version that i have downloaded three days ago i haven't this error.
07-14-2007, 10:42 AM,
I assume you are building on win32? I haven't tested that, but try to go to the line in the file in question and change "$EXECUTABLE_NAME" to "${EXECUTABLE_NAME}" if that fixes the problem, I will update svn.


p.s. you may have another problem running install... if so,there is another thread in the "bugs" forum dealing with that issue
07-14-2007, 12:07 PM,
yes, i'm building on win32 (win2000 sp4). I have solved that problem adding {} in the code, but like you have told me i have another problem but sorry i can't find which post talk about it.
Scons tell me "undefined references to .." a lot of SDL files, for example: SDL_Quit, SDL_strlcpy, SDL_strlcat.....
07-14-2007, 03:34 PM,
Well... the post I referrenced doesn't deal with the issue you describe. I can't say that I can explain what you are seeing. Perhaps if you post the full output that scons provides?

If I can't figure it out, perhaps thelusive can.

07-14-2007, 04:39 PM,
Here there's an screenshot of a part of the erros:
07-14-2007, 05:55 PM,
I guess you need libSDL.a
07-14-2007, 06:37 PM,
mpo Wrote:Here there's an screenshot of a part of the erros:

Hrm... I get an access-denied error when I click that link. I don't know what's up. Can you copy-paste the text?

FFuser suggests that you need libSDL.a... which is possible ( I don't know how mingw requires static libs to be named ), but I think all of the necessary dependencies were checked in to tools/win... and the scons files does tell the compiler/linker to look here.

Just to be clear... everything built fine 3 or 4 days ago?

07-15-2007, 05:32 AM,
Yes, four days ago i have compiled vdrift without errors. I have tried to download SDL library from the site (version 1.2.11) but libSDL.a there isn't in the package, where i can find it?
I have also another question, i have made the SVNupdate of the source code but tortoise tell me that there's a conflict with the file src/SConscript, what does it mean? What i have to do?

07-15-2007, 10:35 PM,
The conflict thing is due to the fact that you (followed my instructions and) modified the file. In the meantime, I updated it. When you updated it using svn, since the same location is editted by two people, it is a conflict. To deal wit this, TortoiseSVN should allow you to right-click on the file and select "revert" or restore or rollback or somethign like that on the context menu. After you do this, you may need to update the file again.

If the codebase was building for you before my commits, than I am assuming that you already have the libs that you need. However, since I could find no errors visually inspecting the scons files, there's not much else I can do without detailed scons output from you. I may be able to test on a windows machine myself... but I don't know when that will be.

Forum Jump:

Users browsing this thread: 1 Guest(s)