Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
in-game transmission: stripping the gears of my computer
05-05-2007, 11:39 AM,
in-game transmission: stripping the gears of my computer
As I post this message, I am still searching through the documentation regards bugs and errors, and so forth. But this problem is getting to me. I haven't tried re-installing VDrift yet, however, technically, it had already been reinstalled to a missing .dll file; this problem was not resolved after giving the folder the .dll file either, so I just reinstalled it and began anew, and it has seemingly been running fine.

SEEMINGLY. I had only brought up the main menu a few times before to configure the display and controls and, as far as I could tell, there was no problem. I am quite certain that this is the most recent version of VDrift for the use on a Windows OS.

Thus, after getting some final control issues resolved, I clicked on practice mode, chose a vehicle (looks like a skyline... but, the model is immaterial), and then started the game with a USB controller configured in the interest of a manual transmission (ie. external clutch, and the up and down shifting buttons).

And so, I began a practice session on a course (weekend something...) and I could hear the engine sound (which, actually, was a sign of progress; originally, no sound had been working at all). The countdown finished and I (note: at this point I hadn't realized that turning the engine on was necessary, but it didn't seem to matter, as the car revved anyway) pressed the clutch, up-shifted to first, released the clutch, and then punched the gas with no result, other than the engine revving. This was the case for much of the time I had been testing it w/ different controls, graphics, etc. and, only once did the car move at all. I can't remember the exact settings, but judging from the result in all times following, I can easily say that I must have turned AutoShift ON, went to the game, still found the manual controls effecting the gears, pressed the ignition button, clutched, up-shifted to first, released the clutch, and then, after about a second, I heard the engine revving, the car had lurched forward slightly, I became elated, and within the next half a second, the entire computer restarted itself. I dunno if this is due to the AutoShift option being on whilst trying to shift manually or if it is a hardware problem on my end, or what. I am going to reinstall the program once more, but if you have ever heard of such a strange result, I would appreciate some advice. However, as I stated, I haven't studied all the various documentation that is on this site and the wiki, but I have covered a bit of it, and the absence of a similar case to my own prompted me to make a post. Thanks.
Fearing that this is the retaliation strategy toward Microsoft,
S.H. Notardonato
05-05-2007, 03:27 PM,
Hi, and welcome to the forums.

I think the problem you're having is that you've set shift buttons but the clutch is not being engaged. You should set the "engage clutch" control to the same thing as your shift up and down buttons. This way, when you press the shift up button, it will disengage the clutch, shift up, and then when you let go of the button, it will engage the clutch. The same goes for the shift down button. You just need to set your two shift buttons to the engage clutch control.

I have no idea why the game restarts your computer, that sounds more like a hardware issue of some kind. What kind of graphics card do you have? What version of the graphics drivers are you using? How much memory is in your system, including video memory?
05-05-2007, 06:49 PM,
Thank you for the response. The way many of the controls work, at first, did confuse me and I thought I had it understood when I mapped my keys initially, but I was far from it, apparently.

As to why my machine is restarting, I have an inkling that once the program is able to function properly, that problem will be solved, as well. Of course, I don't know for sure. However, I can tell you that it wouldn't be a hardware problem in the sense of lacking RAM or capability to play the game as, until I hit that problem, the interface was working fine and without lag. Furthermore, I've been playing video games primarily on a console lately and I haven't gone to the trouble of loading down my computer with the other computer games that I once ran quite frequently (primarily CS:Source, F.E.A.R. and Garry's Mod) and, since they all worked quite well and only showed signs of strain when on the best graphics settings.

Now, however, the most graphically intense program I run on a regular basis is Google Earth, so I will configure VDrift in the manner you described as soon as the .exe downloads again.

Once again, I appreciate the response.
05-05-2007, 06:57 PM,
You shouldn't need to re-download the game to get it to work, it sounds like you had it working before. If it crashes that's possibly a bug. It could also be a problem with your hardware or drivers for hardware, please check that you have the latest nvidia/ATI drivers or whatever is appropriate for your card. If you know of another working OpenGL application then we can probably rule that out. Good luck, and let us know once you try it out again, and we'll try to help you figure out any problems.
05-05-2007, 07:09 PM,
Yeah, I didn't think I would have to redownload it either, but I think I must have accidentally deleted it when I was going to attempt reinstalling the game earlier and was side-tracked.

Anyway, thanks for the help. It does work now. My next obstacle is finishing a research paper after getting it to run... stupid priorities. >_<

Forum Jump:

Users browsing this thread: 1 Guest(s)