Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
opensuse 10.2 vdrift Segmentation Fault
03-28-2007, 11:38 AM,
opensuse 10.2 vdrift Segmentation Fault
I have search,but not get the answer!
I download the source vdrift-2007-03-23-data-full.tar.bz2 to compile,but decompression error.
My english is so poor,so please pardon!
03-28-2007, 03:26 PM,
The data-full package does not contain the source, just the data. You also need the source package. If the data package doesn't decompress properly, then you need to re-download it.

In the topic you say "Segmentation Fault" but don't mention this in your post. How did you get a segfault if you didn't even compile yet?
03-28-2007, 10:52 PM,
This might be related to this problem which we're working on a fix for now...
03-28-2007, 11:00 PM,
I first get the full package and install ,but get the “Segmentation Fault“.
When i click the "single race" or other,the game do nothing.
there are some information:

opensuse:~ # vdrift
BinReloc successfully initialized.
Executable path: /usr/share/games/vdrift/bin/vdrift
Data dir: /usr/share/games/vdrift/data
Localedir: /usr/share/games/vdrift/share/locale
CONFIGFILE.Load: Couldn't find file: /root/.vdrift/VDrift.config
No data_dir found in VDrift.config, using /usr/share/games/vdrift/data
Can't find the settings directory at "/root/.vdrift". Making a new one...
Missing /root/.vdrift/controls file, copying.
Found config file /root/.vdrift/VDrift.config.
No data_dir found in VDrift.config, using /usr/share/games/vdrift/data
Version of game: 2007-03-23
Skin name not found in config file...
Warning: option-47 is missing its default value. Assuming "".
Force feedback device: /dev/input/event0
Force feedback gain: 2
Force feedback inverted: 0
Run with -verbose for troubleshooting.
Run with -nosound to disable sound.
Run with -benchmark to play a replay and output benchmark data.
0 joystick(s) found:
Multitexture: Yes
Texture units: 4
Antialiasing: Yes
Anisotropic texture filtering: Yes
Maximum Anisotropy: 16
Multitexture units (4 are required for all effects): 4
Your GPU meets the texture unit requirements.

Note to user: All error messages will be put in /root/.vdrift/logs/.
Segmentation fault
opensuse:~ #

So I want to compile from the source ,I download the vdrift-2007-03-23-src.tar.bz2 and vdrift-2007-03-23-data-full.tar.bz2.
But When decompression the vdrift-2007-03-23-data-full.tar.bz2 get error .I have re-download,the error still.
there are some information about the error:


bzip2: Data integrity error when decompressing.
Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

My system information:
AMD 3000+
Nvidia 7300GT
1G memory
openSUSE 10.2
gcc version 4.1.2 20061115 (prerelease) (SUSE Linux)
03-28-2007, 11:05 PM,
thelusiv Wrote:This might be related to this problem which we're working on a fix for now...

Ok,I test now !
03-28-2007, 11:15 PM,
On the data-full package, can you tell me the size of the vdrift-2007-03-23-data-full.tar.bz2 on your system by doing:
ls -alh vdrift-2007-03-23-data-full.tar.bz2
and also the md5sum:
md5sum vdrift-2007-03-23-data-full.tar.bz2
03-28-2007, 11:22 PM,
ksuse@opensuse:~> ls -alh vdrift-2007-03-23-data-full.tar.bz2
-rwxrwxrwx 1 ksuse root 221M 03-28 18:28 vdrift-2007-03-23-data-full.tar.bz2
ksuse@opensuse:~> md5sum vdrift-2007-03-23-data-full.tar.bz2
ec2273010ff1dac962236211c2ae2962 vdrift-2007-03-23-data-full.tar.bz2
03-28-2007, 11:28 PM,
Oops, I meant to say,
ls -al
without the h, that rounds off the size. I need to know the number of bytes. Smile
03-28-2007, 11:32 PM,
charlielinux Wrote:
thelusiv Wrote:This might be related to this problem which we're working on a fix for now...

Ok,I test now !

I have test the VDrift-2007-03-23-minimal-2.package ,but still get Segmentation fault
03-28-2007, 11:35 PM,
thelusiv Wrote:Oops, I meant to say,
ls -al
without the h, that rounds off the size. I need to know the number of bytes. Smile

ksuse@opensuse:~> ls -al vdrift-2007-03-23-*
-rwxrwxrwx 1 ksuse root 230921162 03-28 18:28 vdrift-2007-03-23-data-full.tar.bz2
-rw-r--r-- 1 ksuse root 1232857 03-28 09:46 vdrift-2007-03-23-src.tar.bz2
03-29-2007, 12:03 AM,
Well, your md5sum is different than mine, while the number of bytes in the file is the same.

$ md5sum build/vdrift-2007-03-23-data-full.tar.bz2
2136ce2e347a018f2400e3f114e005fd  build/vdrift-2007-03-23-data-full.tar.bz2

Now I wonder if the one on is the same or different. I uncompressed mine and the file worked fine. I guess I need to download it myself and test...I wonder how it could have been corrupted?
03-29-2007, 03:24 AM,
Alright, I downloaded vdrift-2007-03-23-data-full.tar.bz2 from SourceForge again, and was able to unpack it, and got the same md5sum as the one that was on my computer before. charlielinux, I guess the only thing I can tell you is download the file again. Make sure to remove the old one first so it's not in the way.

Forum Jump:

Users browsing this thread: 1 Guest(s)