Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
20070323 autopackage error
03-26-2007, 12:44 PM,
#1
20070323 autopackage error
Hello,
I've tried installing the autopackage of 20070323, the installation finished successfully, and I can access to the main menu and options. But the game crashed when I want to start a new game, whether practice, SP, or MP. I got this error message in console:

Fatal signal: Segmentation Fault (SDL Parachute Deployed)

Does anyone know how to fix it? My distro is Mandriva 2005. Though it's very old by today's standards, I can still run other 3D program & games without any problem.

Thanks in advance for your kindly help.
Reply
03-26-2007, 12:53 PM,
#2
 
Thanks for the report. The package is having problems on lots of systems...I'm trying to figure out a solution but not making much progress. Either way I build the package, it always fails for somebody. I'm not quite sure why, but I'm working with the autopackage developers to find a solution. If you want to play the game I suggest compiling from source, that works well for everyone.
Reply
03-27-2007, 12:14 AM,
#3
 
Thanks for the fast reply. I list some package versions here and hope they would be useful for you to fix the problem.

(Mandriva LE2005)
gcc 3.4.3
glibc 2.3.4
libopenal 0.0.8
libSDL 1.2.8
libSDL_gfx 2.0.13
libSDL_image 1.2.4
libSDL_mixer 1.2.5
libSDL_net 1.2.5
libSDL_ttf 2.0.7
Xorg 6.8.2
Reply
03-27-2007, 03:30 AM,
#4
 
Thanks for the info, we're getting close to tracking down this bug. Could you try out the test package linked here: http://vdrift.net/Forum/viewtopic.php?p=4195#4195

If you could tell me the info from gdb and ldd as described there, it might help fix this problem sooner...
Reply
03-27-2007, 05:42 AM,
#5
 
Hi,
I cannot install the 20070327-debug-2 package because it asked for newer version of glibc (2.4). I have glibc 2.3.4.

I can install the 20070323-minimal-2 package. It still crashed, but the error message became only "Segmentation Fault", no "SDL parachute deployed" this time.

Thanks.
Reply
03-27-2007, 08:40 AM,
#6
 
Alright, thanks for trying that. I think this is due to an apbuild bug because apbuild is supposed to strip out al the glibc 2.4 symbols and not depend on it, it should make it runnable for everyone (that's the whole point), but it appears to not be working. The autopackage devs know about this now...
Reply
03-27-2007, 11:32 PM,
#7
 
Hello,
Just tried debug-2-all-apbuild and debug-2-no-static-x, cannot install both of them due to glibc version. Sad

Thank you for keep tracking this.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)