Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mouse input in the new release
03-24-2007, 02:13 PM,
Mouse input in the new release
Congratulations for the new wonderful release. It's pretty cool and its one of the best free open source projects.

I'm really sorry about the n00b question but how do I have to configure the mouse to use it for steering and accelerating?
When I use the assign controls menu I can configure the mouse the way I want but after that in the game this has no effect.
If i could use mouse in the game the joy would be complete.
03-24-2007, 02:19 PM,
Are you sure its having no effect? Have you turned on the input graph in Options -> Display to see what's happening?

Could you post your controls file?
03-24-2007, 03:10 PM,
Thanks for the quick reply.
I enabled the input graph and I can see that its not moving.
I'm using ubuntu and simple ps2 mouse.

Here is my controls file:
03-24-2007, 03:29 PM,
The connection to the server keeps timing out. Maybe you could try putting it on or something similar instead.
03-25-2007, 06:33 AM,
I'm sorry for the link.
Here is the file:

#Generated by VDrift, feel free to edit manually

# joystick type: wheel or joystick, touchiness compensation
joysticktype joystick off

# for a joystick button:
# [function name] joy [joystick number] button [button number] [true for not held down, false for held down] [true to trigger when button is pressed, false to trigger when button is released]

# for a joystick axis:
# [function name] joy [joystick number] axis [axis number] [true for positive axis, false for negative axis] [deadzone] [exponent] [gain]

# for a keyboard key:
# [fuction name] key [key name as defined in lists/keys] [true for keys that aren't held down, false for keys that are] [true to trigger when key is pressed, false to trigger when key is released]

reset key r false true
neutral key n true true
first_gear key 1 true true
second_gear key 2 true true
third_gear key 3 true true
fourth_gear key 4 true true
fifth_gear key 5 true true
sixth_gear key 6 true true
reverse key BACKQUOTE true true
view_hood key F1 true true
view_incar key F2 true true
view_chaserigid key F3 true true
view_chase key F4 true true
view_orbit key F5 true true
view_free key F6 true true
view_external key F7 true true
view_extfollow key F8 true true
pan_left key KP4 true true
pan_right key KP6 true true
pan_up key KP2 true true
pan_down key KP8 true true
replay_ff key PERIOD true true
replay_rw key COMMA true true
screen_shot key F12 true true
joystick_info key j true true
pause key p true true
disengage_shift_up key w true true
disengage_shift_up mouse button 1 true true
disengage_shift_down key s true true
disengage_shift_down mouse button 3 true true
engage key w true false
engage key s true false
engage mouse button 1 true false
engage mouse button 3 true false
gas mouse motion up
brake mouse motion down
steer_left mouse motion left
steer_right mouse motion right
start_engine key s true true
start_engine mouse button 2 true true
handbrake key SPACE false true

P.S. I compiled vdrift on ia64
03-25-2007, 10:59 AM,
Your controls file looks OK, and I tested mouse controls on my machine and it doesn't work here either. I think it might be a problem related to the new per-control settings, I guess mouse controls haven't been tested since those got added. I'm going to move this topic to Bugs.
03-25-2007, 11:39 AM,
I'm sorry about finding a bug that early but the mouse is the main input available for me and I hope this would be fixed soon.
If there is a way for me to help, I would be glad to.
03-25-2007, 11:56 AM,
No problem - thanks so much for finding and reporting this so quickly. If you want to play around with it, try turning off all deadzone, gain and exponent on the mouse controls (turn them all to the lowest settings), or try setting them to different values, and see what effects that has. I believe this might be related to mouse deadzone, but I'm not certain at all.
03-25-2007, 02:06 PM,
Hmm, mouse steering works for me. How odd....
03-26-2007, 11:51 PM,
joevenzon Wrote:Hmm, mouse steering works for me. How odd....
it doesn't work for me either. something to do with the config options (i tried to back up to a version that worked from a few days ago but still no go).

03-26-2007, 11:53 PM,
Joe can you post your VDrift.config? Or did you clear it before you installed?

It may be due to me removing the mouse options right before release. They weren't in use anymore but maybe there's one hanging around in the code still. I thought I checked and didn't find any in mouse.cpp or
03-27-2007, 02:01 AM,
Okay, nevermind, mouse control doesn't work for me anymore. It must have been something that changed recently, because as of my last post it worked fine (I may not have been working with the latest SVN rev at that point, but I am now).
03-27-2007, 03:07 AM,
Alright I think this is now fixed in SVN r1638. I had forgotten to remove the references to the mouse settings in mouse.cpp, and they were apparently 0, which caused the mouse input to be zeroed out also.
03-27-2007, 05:41 AM,
I tried the new svn and
Mouse input is working now.
Thanks for the efforts and the quick fix.
04-04-2007, 04:39 AM,
Is this fix likely to be released as a formal release sometime soon?

How long should I expect to wait until I can download a working version?

Many thanks.

Forum Jump:

Users browsing this thread: 1 Guest(s)