Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No sound
01-01-2007, 10:22 AM,
No sound
I am running the latest svn on gentoo.

I used to get sound before, but not anymore.
If I run other applications that produce sound like xmms or flash player in firefox they do work.

this is the console's output:

BinReloc successfully initialized.
Executable path: /home/jsantos/Apps/vdrift/build/vdrift
Data dir: /home/jsantos/Apps/vdrift/data
Localedir: /home/jsantos/Apps/vdrift/share/locale
CONFIGFILE::GetParam(): main.data_dir not found in /home/jsantos/.vdrift/VDrift.config
No data_dir found in VDrift.config, using /home/jsantos/Apps/vdrift/data
Found config file /home/jsantos/.vdrift/controls.
Found config file /home/jsantos/.vdrift/VDrift.config.
CONFIGFILE::GetParam(): main.data_dir not found in /home/jsantos/.vdrift/VDrift.config
No data_dir found in VDrift.config, using /home/jsantos/Apps/vdrift/data
Version of game: development
Skin name not found in config file...
Run with -verbose for troubleshooting.
Run with -nosound to disable sound.
Run with -benchmark to play a replay and output benchmark data.
1 joystick(s) found:
0. Microsoft SideWinder Precision Racing Wheel USB version 1.0
Multitexture: Yes
Texture units: 4
Antialiasing: Yes
Anisotropic texture filtering: Yes
Maximum Anisotropy: 8
Multitexture units (4 are required for all effects): 4
Your GPU meets the texture unit requirements.

Note to user: All error messages will be put in /home/jsantos/.vdrift/logs/.
error loading texture file "/home/jsantos/Apps/vdrift/data/tracks/nuerburgring_nordschleife/objects/.png"...

01-05-2007, 05:45 PM,
Please post your version of OpenAL and ALUT.
01-05-2007, 06:04 PM,
OpenAL: 0.0.8-r1

ALUT: freealut 1.0.1
01-05-2007, 06:11 PM,
Are you using ESD/artsd? Does sound work in other OpenAL games? Do you have a ~/.openalrc file?
01-05-2007, 06:55 PM,
I don't use arts or esound, so both where down.

That was it. I didn't know vdrift used esound. I thought it would talk to alsa directly. As soon as I started esound it worked :oops:

Sorry for wasting your time
01-05-2007, 06:59 PM,
VDrift doesn't use Esound, it uses OpenAL. OpenAL has an order for searching for a sound output method. Usually it first tries ALSA, which is what you probably should use if you're not using Gnome's Sound Server, Esound (which it sounds like you are, since that works), or you can use .openalrc to change the order to try artsd or esd first, if you use those.

No worries about wasting time, others have this problem commonly. Anybody got a link to something explaining how to make a .openalrc? I used to, but have lost it...

Forum Jump:

Users browsing this thread: 1 Guest(s)