Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mouse control broken
09-23-2006, 12:40 PM,
#1
mouse control broken
using the latest svn snapshot i seem to have lost the ability to use the mouse to control the car. if i go to options/controls/ i see under controls profile that the keyboard is enabled by default but it is greyed out so pressing the arrows won't change anything. i poked around data/skins/simple/menus/ but i wasn't able to come out with a fix. any ideas?

--alex--
Reply
09-23-2006, 01:00 PM,
#2
 
All you have to do now is assign mouse controls like any other control, and it should work fine. I think maybe up and down might be flipped. I'll check this out today...
Reply
09-23-2006, 01:18 PM,
#3
 
thelusiv Wrote:All you have to do now is assign mouse controls like any other control, and it should work fine. I think maybe up and down might be flipped. I'll check this out today...

i tired that, the up and down are flipped (gas/brake) but i couldn't get the car to shift gears (even though i assigned mouse1/3 to up/down respectively).

--alex--
Reply
09-23-2006, 03:42 PM,
#4
 
alex25 Wrote:
thelusiv Wrote:All you have to do now is assign mouse controls like any other control, and it should work fine. I think maybe up and down might be flipped. I'll check this out today...

i tired that, the up and down are flipped (gas/brake) but i couldn't get the car to shift gears (even though i assigned mouse1/3 to up/down respectively).

--alex--
Did you remember to set the same buttons to Engage Clutch also? I'll check it out...
Reply
09-25-2006, 09:56 AM,
#5
 
thelusiv Wrote:Did you remember to set the same buttons to Engage Clutch also? I'll check it out...

i have the following in my .vdrift/controls:

Code:
disengage_shift_up mouse button 1 true true
disengage_shift_down mouse button 3 true true
engage key SPACE true true

there is only one entry in the menu to engage the clutch. so i tried pressing the mouse button followed by the space bar but nothing happened. the car just sits there in neutral.

--alex--
Reply
09-30-2006, 02:56 PM,
#6
 
thelusiv Wrote:Did you remember to set the same buttons to Engage Clutch also? I'll check it out...

it works now after the latest svn update. i have to admit that i like the old behaviour better (i especially miss the mouse controls display on the screen) but i guess i'll get used to the new one at some point. thanks.

--alex--
Reply
09-30-2006, 03:51 PM,
#7
 
You can still set it up exactly like it was before. Set gas/brake to mouse up and mouse down. Set steer left/right to mouse left and mouse right respectively. Then set Shift up to right click, and Shift down to left click. Finally, set Engage clutch to both right click and left click. That's it.

As for the old indicators on screen I have made them general so any input can use them. Just go to Options -> Display, then change "Input Graphing" to "On".
Reply
10-11-2006, 01:25 PM,
#8
 
thelusiv Wrote:You can still set it up exactly like it was before. Set gas/brake to mouse up and mouse down. Set steer left/right to mouse left and mouse right respectively. Then set Shift up to right click, and Shift down to left click. Finally, set Engage clutch to both right click and left click. That's it.

i've pretty much have it set up like it was before but there is still one thing that bothers me. i shift up/down using the mouse left/right buttons and then engage in gear by pressing the spacebar. wouldn't it make more sense to press the spacebar to engage the clutch shift up/down using the mouse and then, when i release the spacebar, engage in gear. this would be more in line with the way the clutch works on a real car.

second, is there some kind of mail gateway to this web-based forum? i have to admit i would much prefer to follow the discussions using email rather than a web broswer. thanks.

--alex--
Reply
10-11-2006, 01:58 PM,
#9
 
Alex, I agree it would be nice to have the clutch be totally separate from the shifting. Right now to "push in" the clutch, one must shift a gear. It will take some work to unbind these two controls, but it's not a bad idea.

The forum uses email to tell people about updates to subscribed threads, but other than that there's no way to use the forum with email.

Some people have asked why we don't use mailing lists. There are a number of reasons...for one, the server this site runs on can't run a mail server which receives mail. Second, I've heard SF.net's mailing lists aren't the best. Third, to have both a mailing list and a forum would mean some people would only use one or the other, but I would have to use both, and this would drive me crazy.
Reply
10-12-2006, 12:18 AM,
#10
 
Quote:It will take some work to unbind these two controls, but it's not a bad idea.

I'm going off of memory here, but I think this would be fairly easy to do, if it's desired.

By the way, have you tried binding the spacebar to the analog clutch control?
Reply
10-13-2006, 04:36 PM,
#11
 
joevenzon Wrote:By the way, have you tried binding the spacebar to the analog clutch control?

i just tried it, nothing happened. i could still shift gears without engaging the clutch (pressing the spacebar) and releasing the spacebar didn't engage in gear.

--alex--
Reply
10-13-2006, 08:17 PM,
#12
 
Turn off Autoclutch in the Options menu and try again
Reply
10-13-2006, 08:43 PM,
#13
 
joevenzon Wrote:Turn off Autoclutch in the Options menu and try again

it is (was) off.

--alex--
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)