Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problem in ubuntu dapper amd64
06-30-2006, 12:03 PM,
problem in ubuntu dapper amd64
Hi guys!

I have this problem when I run the "./configure"

checking for alutInit in -lopenal... no
configure: error: *** OpenAL 1.0 library not found!

Ok, but I have installed this lib in /usr/lib.

but, the name is not the same, so I don't know if this library is the correct. The name of the library is:
libopenal0a or liboal

What's happen in this case?
Someone can help me?

thanks a lot!

06-30-2006, 12:49 PM,
Hmmm, that's strange...VDrift doesn't use ./configure, unless you got a really old version. we use scons
06-30-2006, 01:03 PM,

This is true, my version was very old(2005), but I got the new version and the same error appears:

You do not have the openal library installed. Exiting.

What is the correct name of the library to install in ubuntu dapper adm64?

thanks a lot for help me!

06-30-2006, 02:30 PM,

Are the packages I have installed, but I'm not using amd64 but an Intel Pentium 4 32 bits
06-30-2006, 05:12 PM,
are you running 64 bit? I had the problem with 64 bit in the /lib. It gave a elf format error. Mine is in /lib64. which works for me, not sure on your distro.

06-30-2006, 06:06 PM,
Hello again!

Yes, I running 64 bits(AMD64) and in my /usr/lib or /usr/lib64 I have this libs: libalut.a

Ok, I trying find the packages of this 4 libraries by apt-get:


And this libraries doesn't exist in apt-get.
Another test was opened the SConstruct and change the /lib to /lib64, but still doesn't work
Any other idea?

06-30-2006, 07:53 PM,
Well I'm checking my system (FC5) and i don't see that file called, also
ldd -v vdrift returns (cut for space) => /usr/lib64/ (0x000000312e900000) => /usr/lib64/ (0x00002aaaaaac4000)
Version information:
/usr/lib64/ (GLIBC_2.2.5) => /lib64/ (GLIBC_2.2.5) => /lib64/ (GLIBC_2.3) => /lib64/ (GLIBC_2.4) => /lib64/ (GLIBC_2.3.4) => /lib64/ (GLIBC_2.2.5) => /lib64/ (GLIBC_2.2.5) => /lib64/
/usr/lib64/ (GLIBC_2.4) => /lib64/ (GLIBC_2.3.4) => /lib64/ (GLIBC_2.2.5) => /lib64/ (GLIBC_2.2.5) => /lib64/


libopenal-devel is in openal-devel
alut and alut-devel look to be needed

ALSO you could try to use the old openal system
scons old_openal=1

When you said you have the new version did you mean svn? if not try it, as the release won't build on mine either.

07-01-2006, 01:56 PM,
Hello again guys!

Look, I tried using this command : scons old_openal=1

But, the same error appears.
This command didn't work in my computer: ldd -v vdrift

Someone run this game in 64 Bits? Because I think the problem is exactly this! There are no libraries to run the game in 64 bits.

I still try running the game, but with no sucess!

Thanks for your help!

07-01-2006, 02:01 PM,
sorry, I forgot in ask:

How I can get the SVN version? I enter in the link above, but wich version I need get?
When I enter in Vdrift link, there are 3 other options(branch, tags, trunck) but I think is neither of this options, correct?


07-01-2006, 06:59 PM,
You want the trunk. To check out the trunk so you can compile it on your computer (assuming you're not running Windows) do this:

svn co vdrift

It will take a while to download everything but once done you will have the latest development version.

To do the above of course you will need the subversion client installed on your computer.
07-07-2006, 06:08 PM,
dragoncool Wrote:Someone run this game in 64 Bits? Because I think the problem is exactly this! There are no libraries to run the game in 64 bits.

i run it on an amd64 under debian linux. no problems whatsoever. i am not sure what you mean by there are no 64-bit libraries to run the game.


Forum Jump:

Users browsing this thread: 1 Guest(s)