Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vdrift won't start (vdrift: symbol lookup error: vdrift: undefined symbol: _ZN15btCo)
08-26-2015, 08:18 AM (This post was last modified: 08-26-2015 09:56 AM by jenn4.)
Post: #1
Vdrift won't start (vdrift: symbol lookup error: vdrift: undefined symbol: _ZN15btCo)
[SOLVED! Downgrading bullet fixes the problem.]

Vdrift did work for a couple of days. Then I started getting this message on the terminal when starting: 'vdrift: symbol lookup error: vdrift: undefined symbol: _ZN15btCompoundShapeC1Eb'. I tried re-installing the game from standard repositories and from the AUR. No help. I've then compiled from git and for the latest try from the .7z nightly. Still the same error.

I tried to look on google, but I get only some bug reports from 2009 saying an update fixed everything.

I have tried re-installing and removing all related files and everything obvious like that.

When I run the game, the loading bar comes up, finishes, and then the crash happens.

Output: In order to view links, you must have to reply to this thread.

System information:
OS: Manjaro 0.8.13.1 Ascella
Kernel: x86_64 Linux 4.1.6-1-MANJARO
CPU: Intel Core i5-3570K 3.8GHz
GPU: ASUS R9 280x
GPU driver: Catalyst
Find all posts by this user
Quote this message in a reply
08-26-2015, 08:39 AM
Post: #2
RE: Vdrift won't start
btCompoundShape comes from Bullet.
Just a guess, make sure you have a package installed, called libbullet or similar that has Bullet Physics library.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-26-2015, 09:55 AM
Post: #3
RE: Vdrift won't start
(08-26-2015 08:39 AM)CrystalH Wrote: In order to view links, you must have to reply to this thread.btCompoundShape comes from Bullet.
Just a guess, make sure you have a package installed, called libbullet or similar that has Bullet Physics library.

I found out that the bullet package had been updated earlier this week. I downgraded the package, and now everything works fine. Thank you for help.
Find all posts by this user
Quote this message in a reply
08-26-2015, 10:13 AM
Post: #4
RE: Vdrift won't start
(08-26-2015 09:55 AM)jenn4 Wrote: In order to view links, you must have to reply to this thread.
(08-26-2015 08:39 AM)CrystalH Wrote: In order to view links, you must have to reply to this thread.btCompoundShape comes from Bullet.
Just a guess, make sure you have a package installed, called libbullet or similar that has Bullet Physics library.

I found out that the bullet package had been updated earlier this week. I downgraded the package, and now everything works fine. Thank you for help.

Hi jenn4. Could you post the bullet lib versions (breaking, working)?
Find all posts by this user
Quote this message in a reply
08-26-2015, 10:19 AM
Post: #5
RE: Vdrift won't start
(08-26-2015 10:13 AM)NaN Wrote: In order to view links, you must have to reply to this thread.
(08-26-2015 09:55 AM)jenn4 Wrote: In order to view links, you must have to reply to this thread.
(08-26-2015 08:39 AM)CrystalH Wrote: In order to view links, you must have to reply to this thread.btCompoundShape comes from Bullet.
Just a guess, make sure you have a package installed, called libbullet or similar that has Bullet Physics library.

I found out that the bullet package had been updated earlier this week. I downgraded the package, and now everything works fine. Thank you for help.

Hi jenn4. Could you post the bullet lib versions (breaking, working)?

Sure: Working bullet version: bullet-2.83.5-1-x86_64.
Not working version (latest): bullet-2.83.6-1-x86_64.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)