Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Test build 2014-08-11
08-11-2014, 03:22 PM,
#1
Test build 2014-08-11
Linux: http://sourceforge.net/projects/vdrift/f...2/download

Windows: http://sourceforge.net/projects/vdrift/f...z/download

For windows it is a full recompile, due to compiler update.

The build also contains the latest translation updates and a few minor fixes.
Reply
08-12-2014, 03:52 AM, (This post was last modified: 08-12-2014, 04:18 AM by CrystalH.)
#2
RE: Test build 2014-08-11
Uh weird bug. There isn't pl in menu (to choose language).
But the number of languages seems bigger or sth. And if you pick eg. uk, then on next run you have ru (previous one).
I had pl in .config and it got lost to de on next run (have to enter Display menu before, if you don't it stays).

Ive downloaded brands from the updates menu, it has some skybox bug.
http://imgur.com/gcLrk0C
Mostly front is just black, the sides seem to show up, sometimes flickering.
Reply
08-12-2014, 04:19 AM, (This post was last modified: 08-12-2014, 04:44 AM by NaN.)
#3
RE: Test build 2014-08-11
(08-12-2014, 03:52 AM)CrystalH Wrote: Uh weird bug. There isn't pl in menu (to choose language).
But the number of languages seems bigger or sth. And if you pick eg. uk, then on next run you have ru (previous one).
I had pl in .config and it got lost to de on next run (have to enter Display menu before, if you don't it stays).

Oops, the game still was looking in the old skin language directory, only worked by accident. I really should remove it.

Will upload a fixed version asap.



(08-12-2014, 03:52 AM)CrystalH Wrote: Ive downloaded brands from the updates menu, it has some skybox bug.
http://imgur.com/gcLrk0C
Mostly front is just black, the sides seem to show up, sometimes flickering.

Does that happen with gl2 renderer too? I know gl3 has slight differences, is on my todo to go through the code.



Language selection fix is up.

Linux: Just grab the source from github Smile https://github.com/VDrift/vdrift/

Windows: http://sourceforge.net/projects/vdrift/f...z/download
Reply
08-12-2014, 02:08 PM, (This post was last modified: 08-12-2014, 02:15 PM by CrystalH.)
#4
RE: Test build 2014-08-11
Right. Language works.
I'm sorry to inform but the input bind stuck still happens.
It doesn't on 1st bind. But I have it on next.
(While moving mouse up and pressing bind for brake after I just bound throttle key).
Ugh nope. It just happened on 1st bind too.

Graphics options are ok. I got anisotropy 1,2,4,8,16 and antialiasing off,2x,4x.
Lol. I got 800 fps with gl2 basic in menu and about 1000 in game (although fps value goes 50 up or down fast).
I got about 120 fps with gl2 deferred.
And yes in both gl2 the sky on brands is good.
I'd also say that I like the brightness and colors with gl2 more than gl3.
Reply
08-12-2014, 02:28 PM, (This post was last modified: 08-12-2014, 02:42 PM by NaN.)
#5
RE: Test build 2014-08-11
(08-12-2014, 02:08 PM)CrystalH Wrote: Right. Language works.
I'm sorry to inform but the input bind stuck still happens.
It doesn't on 1st bind. But I have it on next.
(While moving mouse up and pressing bind for brake after I just bound throttle key).
Ugh nope. It just happened on 1st bind too.

Graphics options are ok. I got anisotropy 1,2,4,8,16 and antialiasing off,2x,4x.
Lol. I got 800 fps with gl2 basic in menu and about 1000 in game (although fps value goes 50 up or down fast).
I got about 120 fps with gl2 deferred.
And yes in both gl2 the sky on brands is good.
I'd also say that I like the brightness and colors with gl2 more than gl3.

Thanks a lot for testing CrystalH.

The binding logic is something I really need to look into, maybe rewrite it from scratch instead of hacking around.

I'll add the gl3 sky rendering and the bindig bugs to the issue tracker. Will try to address them asap.

And maybe I'll even manage to make a release this summer, lol.

PS:
The different look is due to the tone mapping shader of the gl3 renderer. Could be tweaked. Other things have higher priority currently though.
Reply
08-12-2014, 02:39 PM,
#6
RE: Test build 2014-08-11
(08-12-2014, 02:28 PM)NaN Wrote: And maybe I'll even manage to make a release this summer, lol.

Yup. Would be definitely cool. It's been a long while.
Especially if it had the new tweakable gauges Rolleyes
Reply
08-13-2014, 10:22 AM,
#7
RE: Test build 2014-08-11
And in the end it turned out to be not the control but the gui page fade in/out logic.

If you manage to trigger(assign) a control before the assign page has finished fading in, you will be stuck in it. Tongue
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)