Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
03-17-2013, 03:54 AM
Post: #1
Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
Hi,

I just installed vdrift through playondeb. When starting from command line i get this error:

xxx@xxxxxx:~$ vdrift -verbose
vdrift: error while loading shared libraries: libBulletDynamics.so.2.80: cannot open shared object file: No such file or directory

when I try with gdb (found in this forum), I get:

xxx@xxxxx:~$ gdb vdrift
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright © 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/games/vdrift...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/games/vdrift
/usr/games/vdrift: error while loading shared libraries: libBulletDynamics.so.2.80: cannot open shared object file: No such file or directory
[Inferior 1 (process 3529) exited with code 0177]
(gdb) exit
Undefined command: "exit". Try "help".
(gdb) quit
xxx@xxxxxxx:~$

Anyone any ideas? I am guessing it has something to do with In order to view links, you must have to reply to this thread. but this should come installed with the game no?

thanks in advance for any advice
Find all posts by this user
Quote this message in a reply
03-17-2013, 08:07 PM
Post: #2
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
Hi, try:

apt-get install libbullet
Find all posts by this user
Quote this message in a reply
03-19-2013, 03:15 PM
Post: #3
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
(03-17-2013 08:07 PM)NaN Wrote: In order to view links, you must have to reply to this thread.Hi, try:

apt-get install libbullet

Hi,

I tried, but I got E: Unable to locate package libbullet

I searched for the correct repository but couldn't find it. I did install playdeb though, I guess the libraries were in that package?

tx,

T
Find all posts by this user
Quote this message in a reply
03-19-2013, 04:10 PM
Post: #4
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
I am not using debian/buntu. But I think it is called libbullet0: In order to view links, you must have to reply to this thread.
Find all posts by this user
Quote this message in a reply
03-21-2013, 01:33 PM
Post: #5
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
xxx@xxxxx:~$ sudo apt-get install libbullet0
Reading package lists... Done
Building dependency tree
Reading state information... Done
libbullet0 is already the newest version.
libbullet0 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 36 not upgraded.

again no luck Sad
Find all posts by this user
Quote this message in a reply
03-21-2013, 03:43 PM
Post: #6
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
If I had to guess I would say the playdeb guys have updated bullet lib to 2.81 but didn't rebuild vdrift. I'd suggest to report the issue to them, so that they can fix it.
Find all posts by this user
Quote this message in a reply
03-22-2013, 06:41 AM
Post: #7
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
(03-21-2013 03:43 PM)NaN Wrote: In order to view links, you must have to reply to this thread.If I had to guess I would say the playdeb guys have updated bullet lib to 2.81 but didn't rebuild vdrift. I'd suggest to report the issue to them, so that they can fix it.

seems logic! I sent them a message

tx for the help.

T
Find all posts by this user
Quote this message in a reply
03-23-2013, 06:51 AM
Post: #8
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
Quote:I tried compiling with bullet 2.81 but it fails with this message:
src/cardynamics.cpp: In static member function 'static bool
CARDYNAMICS::WheelContactCallback(btManifoldPoint&, const btCollisionObject*,
int, int, const btCollisionObject*, int, int)':
src/cardynamics.cpp:1807:77: error: 'const class btCollisionObject' has no
member named 'getRootCollisionShape'
scons: *** [build/cardynamics.o] Error 1

Because you are registered in the forum, can you please ask if bullet 2.81 is
supported by vdrift.

Hey I just got word from they guys at playdeb (see quote above). Does vdrift support bullet 2.81?

tx

T
Find all posts by this user
Quote this message in a reply
03-23-2013, 08:05 AM
Post: #9
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
There is a patch for the last release In order to view links, you must have to reply to this thread.
Find all posts by this user
Quote this message in a reply
03-24-2013, 01:10 AM
Post: #10
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
(03-23-2013 08:05 AM)NaN Wrote: In order to view links, you must have to reply to this thread.There is a patch for the last release In order to view links, you must have to reply to this thread.

Dear NaN,

could you please tell me what do you do with this patch, where do I have to copy it ?

Thanks beforehand for your help.

Ivan.
Find all posts by this user
Quote this message in a reply
03-24-2013, 09:55 AM
Post: #11
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
Place the diff into vdrift directory(unpacked tar.bz2) and run:
patch < vdrift-2012-07-22c_bullet281_patch.diff
Find all posts by this user
Quote this message in a reply
03-27-2013, 03:44 PM
Post: #12
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
(03-24-2013 09:55 AM)NaN Wrote: In order to view links, you must have to reply to this thread.Place the diff into vdrift directory(unpacked tar.bz2) and run:
patch < vdrift-2012-07-22c_bullet281_patch.diff

Hi, thanks for your help but I have an issue with the command:

root@xxxxx:/usr/share/games/vdrift# patch < vdrift-2012-07-22c_bullet281_patch.diff
(Stripping trailing CRs from patch.)
can't find file to patch at input line 3
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
--------------------------
|--- data/skins/simple/menus/AssignControl Mon Jan 19 23:26:36 1970
|+++ data/skins/simple/menus/AssignControl Mon Jan 19 23:26:36 1970
--------------------------
File to patch:

it ends in a prompt? what should I put in?

thx in adv
Find all posts by this user
Quote this message in a reply
03-27-2013, 08:54 PM
Post: #13
RE: Ubuntu 12.04 (x64): libBulletDynamics.so.2.80 error
Yeah, it is a relative path patch. Use:
patch -p0 < vdrift-2012-07-22c_bullet281_patch.diff
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)