Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Error loading GUI page after vdrift-data update
05-12-2012, 07:23 PM,
[SOLVED] Error loading GUI page after vdrift-data update
Dear VDrift team,

first of all I'd like to thank you for your excellent work. VDrift has really been a joy to play - fantastic thing for occasional gamers like me.

I have installed VDrift from the PlayDeb sources on my Ubuntu 12.04 (Precise) machine and it worked out pretty well. However, what bothered me was the limited choice of tracks and cars. I tried to download these (entire tracks/ and cars/ folders, g-zipped from the SVN web repositories) and put those missing tracks and cars into my corresponding directories. That didn't work out. The new tracks and cars showed up in the game, but didn't have a preview. And when I selected them to race with, the game started to load but then immediately jumped back to the menu.

Anyway, so I thought I'd go another way and replace my entire vdrift-data folder. I checked out the sources to /usr/share/games/vdrift/data, using the command
cd /usr/share/games/vdrift
svn co data
which probably isn't the best solution (since that's the directory used by the VDrift Ubuntu packages) but I really don't want to bother myself with compiling the sources and the update cycle is probably so not so fast anyway. To make a long story short, that didn't work either. I now get the following error on startup:
ERROR: Error loading GUI page: /usr/share/games/vdrift/data/skins/simple/menus/AssignControl
ERROR: Error loading GUI files
ERROR: Error initializing graphical user interface
INFO: Exiting
I have found another forum entry [1] with the same error, but the suggestion was to update vdrift-data. I can't really see the point in my case, since the update even caused the whole problem. Subversion says it's revision 1019 which is supposed to be the latest revision, isn't it?

I thought maybe the revision is too new. Am I using a development version that doesn't get along with the Ubuntu package (version from 2011-10-22 according to package name)? But in fact, I really have no idea. Of course I could reinstall the Ubuntu vdrift-data package, but I really want to have all the cars and tracks available. So I'd really appreciate of you could help me out and suggest what could be going wrong here (or a better way to import all cars and tracks to the Ubuntu version)?

Thanks a lot and keep on the great work!

Regards, danpo

05-13-2012, 02:39 AM,
Hi danpo.

The safest way would be to use 2011-10-22 data. There have been just too many changes since then. Some of them not backwards compatible, unfortunately.
05-14-2012, 03:14 AM,
Hi NaN, that made the job for me. Thanks a lot!

For others that might have the same problem: You can simpy checkout or de-grade to an older revision (in this case: 917) by adding the -r option to SVN, i.e.:
svn co -r 917 data
to checkout vdrift-data or
svn update -r 917
if you have -- like me -- already updated to the latest revision and want to de-grade.

Forum Jump:

Users browsing this thread: 1 Guest(s)