Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error with X11
04-07-2012, 06:26 AM
Post: #1
Error with X11
Hi friends,

I have successfully installed VDrift without error, but I can not run game. I get following error:
Code:
fico@debian:~/Downloads/vdrift-src-2011-09-01/build$ ./vdrift
INFO: Multi-processor system detected.  Run with -multithreaded argument to enable multithreading (EXPERIMENTAL).
INFO: Starting VDrift: development-full, Version: , O/S: Unix
INFO: Home directory: /home/fico
INFO: Settings file: /home/fico/.vdrift/VDrift.config (does not exist, will be created)
INFO: Data directory: /usr/local/share/games/vdrift/data
      DATA_DIR: /usr/local/share/games/vdrift/data
INFO: Temporary directory: /home/fico/.vdrift/tmp
INFO: Log file: /home/fico/.vdrift/log.txt
ERROR: Failed to load /home/fico/.vdrift/VDrift.config
INFO: The last VDrift startup was unsuccessful.
      Settings have been set to failsafe defaults.
      Your original VDrift.config file was backed up to VDrift.config.backup
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
ERROR: Display change failed: 800x600x16 16z fullscreen=0
ERROR: Error: X11 driver not configured with OpenGL
vdrift: src/window.cpp:122: void WINDOW_SDL::ChangeDisplay(int, int, int, int, bool, unsigned int, bool, std::ostream&, std::ostream&): Assertion `0' failed.
INFO: SIGABRT detected, releasing the mouse
Aborted

I have no idea, what is wrong, but it is obvious, that troubles are with my graphic settings. Device informations:
Code:
VGA compatible controller : ATI Technologies Inc Device 95c2
Memory : 256MB (32-bit, prefetchable)

My system is ( uname -a ):
Code:
Linux debian 2.6.32-5-686 #1 SMP Wed Jan 12 04:01:41 UTC 2011 i686 GNU/Linux

If you need some more informations, just let me know. Thanks in advance for all your responses.
Find all posts by this user
Quote this message in a reply
04-07-2012, 07:12 AM
Post: #2
 
Hi Fico.
The game requires OpenGL support. Run glxinfo. Also google for "X11 driver not configured with OpenGL". Did you compile SDL by yourself? Are you able to run other 3d games?
Find all posts by this user
Quote this message in a reply
04-07-2012, 10:31 AM
Post: #3
 
NaN: Thanks for your quick reply. glxinfo give me this log:
Code:
name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  135 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

Do you know, why I got this error? A few minutes ago I have totaly reinstalled my graphic driver ( last release ). It didn't help. About SDL - yes, I have compiled it myself, because I am using it for developing ( but not with OpenGL support ). I have not tried any other 3D game, but I tried Google Earth a moment ago and it doesn't work too with this log:
Code:
Stacktrace from glibc:
./libgoogleearth_free.so(+0xc1583)[0xb768c583]
./libgoogleearth_free.so(+0xc1703)[0xb768c703]
[0xb76fe400]
/usr/lib/libX11.so.6(XInitExtension+0x3b)[0xb656661b]
/usr/lib/libXext.so.6(XextAddDisplay+0x4c)[0xb6533b1c]
/usr/lib/libGL.so.1(+0x56d90)[0xb6490d90]

Do you have any idea, how to fix this issue? ( of course I am trying to find answer on google, but no success for now )
Find all posts by this user
Quote this message in a reply
04-07-2012, 11:11 AM
Post: #4
 
You have to compile SDL with --enable-video-opengl option.

Quote:Major opcode of failed request: 135 (GLX)
Means you've messed up the driver installation. Try a clean deinstall and reinstall again. glxinfo/fglrxinfo should run without any errors.

A few links to get an idea:
In order to view links, you must have to reply to this thread.
In order to view links, you must have to reply to this thread.

Maybe this?
In order to view links, you must have to reply to this thread.
Find all posts by this user
Quote this message in a reply
04-07-2012, 12:39 PM
Post: #5
 
NaN: thank you, now I am a little further, but it still doesn't work.

1.) after reinstalling SDL error "ERROR: Display change failed: 800x600x16 16z fullscreen=0" didn't show anymore, but glxinfo still showed errors.
2.) after completely reinstalling xserver-xorg, glxinfo works fine - but WITHOUT installing drivers for my graphic card after that! Because after installing them glxinfo crashes again!

Now I got this error:
Code:
INFO: Multi-processor system detected.  Run with -multithreaded argument to enable multithreading (EXPERIMENTAL).
INFO: Starting VDrift: development-full, Version: , O/S: Unix
INFO: Home directory: /home/fico
INFO: Settings file: /home/fico/.vdrift/VDrift.config (does not exist, will be created)
INFO: Data directory: /usr/local/share/games/vdrift/data
      DATA_DIR: /usr/local/share/games/vdrift/data
INFO: Temporary directory: /home/fico/.vdrift/tmp
INFO: Log file: /home/fico/.vdrift/log.txt
ERROR: Failed to load /home/fico/.vdrift/VDrift.config
INFO: The last VDrift startup was unsuccessful.
      Settings have been set to failsafe defaults.
      Your original VDrift.config file was backed up to VDrift.config.backup
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
INFO: Display change was successful: 800x600x16 16z fullscreen=0
ERROR: You don't have an NVIDIA or ATI/AMD card.  This game may not run correctly or at all.
INFO: Video card information:
      Vendor: Mesa Project
      Renderer: Software Rasterizer
      Version: 2.1 Mesa 7.7.1
      Maximum texture size: 4096
      Maximum varying floats: 64
      Using GLEW 1.5.4
INFO: Your video card doesn't support floating point textures.  Disabling shaders.
ERROR: Unable to open graphics config file: /usr/local/share/games/vdrift/data/shaders/render.conf.noshaders
ERROR: Error loading non-shader render configuration file: /usr/local/share/games/vdrift/data/shaders/render.conf.noshaders
vdrift: src/graphics_fallback.cpp:621: void GRAPHICS_FALLBACK::DisableShaders(const std::string&, std::ostream&): Assertion `0' failed.
INFO: SIGABRT detected, releasing the mouse
Aborted

Your answers are very helpful, but for now, I understand, that problem is somewhere in my drivers and graphic settings, so maybe I have to ask in other forum. Anyway, feel free to give me any other helpful steps, if you want. Thank you very much for your time.
Find all posts by this user
Quote this message in a reply
04-07-2012, 05:50 PM
Post: #6
 
Without installing the driver you will get the software fallback, only of use for the most simple stuff.

Try a debian oriented forum or irc channel. The guys there should be more capable to help you with this issue.
Find all posts by this user
Quote this message in a reply
04-07-2012, 05:57 PM
Post: #7
 
NaN Wrote:Without installing the driver you will get the software fallback
Yes, you are right, because glxinfo | grep renderer give me:
Code:
OpenGL renderer string: Software Rasterizer

OK, as you said, I will ask in a related forum. Thanks again for your valuable time.
Find all posts by this user
Quote this message in a reply
04-08-2012, 09:15 AM
Post: #8
 
Hi, I am back, for now with functional graphic drivers. Any other 3D graphic software works fine now ( for example google-earth ). But I have troubles with vdrift still. This is my last result:
Code:
INFO: Multi-processor system detected.  Run with -multithreaded argument to enable multithreading (EXPERIMENTAL).
INFO: Starting VDrift: development-full, Version: , O/S: Unix
INFO: Home directory: /home/fico
INFO: Settings file: /home/fico/.vdrift/VDrift.config (does not exist, will be created)
INFO: Data directory: /usr/local/share/games/vdrift/data
      DATA_DIR: /usr/local/share/games/vdrift/data
INFO: Temporary directory: /home/fico/.vdrift/tmp
INFO: Log file: /home/fico/.vdrift/log.txt
ERROR: Failed to load /home/fico/.vdrift/VDrift.config
INFO: The last VDrift startup was unsuccessful.
      Settings have been set to failsafe defaults.
      Your original VDrift.config file was backed up to VDrift.config.backup
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
INFO: Display change was successful: 800x600x16 16z fullscreen=0
INFO: Video card information:
      Vendor: ATI Technologies Inc.
      Renderer: ATI Mobility Radeon HD 3430
      Version: 3.3.10188 Compatibility Profile Context
      Maximum texture size: 8192
      Maximum varying floats: 64
      Using GLEW 1.5.4
INFO: Maximum color attachments: 8
INFO: Maximum draw buffers (1 required): 8
INFO: Disabling shaders
ERROR: Unable to open graphics config file: /usr/local/share/games/vdrift/data/shaders/render.conf.noshaders
ERROR: Error loading non-shader render configuration file: /usr/local/share/games/vdrift/data/shaders/render.conf.noshaders
vdrift: src/graphics_fallback.cpp:621: void GRAPHICS_FALLBACK::DisableShaders(const std::string&, std::ostream&): Assertion `0' failed.
INFO: SIGABRT detected, releasing the mouse
Aborted

Do you think, the problem is still in my graphic settings? I am looking forward to your advice. Thanks.
Find all posts by this user
Quote this message in a reply
04-08-2012, 12:56 PM
Post: #9
 
Driver looks fine. I think you are running into issue 81 In order to view links, you must have to reply to this thread.

I'll do a check asap, just busy with other things(would be great if we had a linux maintainer to look for this stuff).
Find all posts by this user
Quote this message in a reply
04-08-2012, 03:39 PM
Post: #10
 
OK, I will wait for any feedback. If you want to check some concretely stuffs, kindly tell me how can I help to figure out this issue.
Find all posts by this user
Quote this message in a reply
04-08-2012, 09:00 PM
Post: #11
 
What installation process did you use? Do any other files exist in /usr/local/share/games/vdrift/data/shaders? I suspect you either installed an old data package or didn't install the data.
Find all posts by this user
Quote this message in a reply
04-09-2012, 03:53 AM
Post: #12
 
Hi joevenzon,

I installed the game from In order to view links, you must have to reply to this thread., with name vdrift-src-2011-09-01.tar.bz2. Is there any other source package which I have to install yet?

joevenzon Wrote:Do any other files exist in /usr/local/share/games/vdrift/data/shaders?
No, I don't have folder /usr/local/share/games and after this command as root:
Code:
find / -name "*vdrift*" -print
it prints only:
1.) folder, where are my source files stored ( the entire folder has 159.9 MB size )
2.) ~/.vdrift
3.) /usr/local/bin/vdrift
Find all posts by this user
Quote this message in a reply
04-09-2012, 04:52 AM
Post: #13
 
The September tarball contained only the sources, no data. People found it too cumbersome to get the data from sourceforge in a separate step. This has been addressed in the following October release which contained the data again(the same as the windows setup). The links here haven't been updated. Anyways, here is the releases root directory: In order to view links, you must have to reply to this thread.
Find all posts by this user
Quote this message in a reply
04-09-2012, 06:46 AM
Post: #14
 
OK, all I need to do, is download package from october ( vdrift-2011-10-22.tar.bz2 ) ? Size is much bigger, so it could help ( 591.2 MB ). I will take a look at it and give you feedback after reinstalling.
Find all posts by this user
Quote this message in a reply
04-13-2012, 03:45 AM
Post: #15
 
Hi all,

sorry for a long break, but I didn't have enough time. I have to thank to you, because with new package everything works fine! Thanks for professional support from your team ( especially thanks to NaN ), have a nice day.

-Fico-
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)