Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
camber, caster and toe
02-15-2012, 12:32 PM
Post: #1
camber, caster and toe
hi all again,
after some tests seems that camber, caster and toe are graphically visibile only when I steer for example, i've putted a camber of 10 (big but only to test) and if I don't steer the wheels are perfectly perpendicular to the ground...

why this?

www.ghiboz.com
Find all posts by this user
Quote this message in a reply
02-15-2012, 02:55 PM
Post: #2
 
Good catch. The bug must have been there since the coordinate system cleanup.

Can you try the latest code? It assumes zero king pin inclination. Run with -debug to check camber.
Find all posts by this user
Quote this message in a reply
02-16-2012, 04:55 AM
Post: #3
 
NaN Wrote:Good catch. The bug must have been there since the coordinate system cleanup.

Can you try the latest code? It assumes zero king pin inclination. Run with -debug to check camber.
yes! now works the camber and the toe, the caster seems that doesn't affect the wheel rotation

www.ghiboz.com
Find all posts by this user
Quote this message in a reply
02-16-2012, 05:29 AM
Post: #4
 
Quote:caster seems that doesn't affect the wheel rotation
Try camber and toe zero and caster 30. The effect should be clearly visible.
Find all posts by this user
Quote this message in a reply
02-16-2012, 06:21 AM
Post: #5
 
NaN Wrote:
Quote:caster seems that doesn't affect the wheel rotation
Try camber and toe zero and caster 30. The effect should be clearly visible.

mmmm something is different... i'll try better...
a question, is a good idea change the sign of the right wheels? so the negative camber is correct ( both wheels will have the same value )

www.ghiboz.com
Find all posts by this user
Quote this message in a reply
02-16-2012, 06:58 AM
Post: #6
 
The simulation doesn't differentiate between left and right side. In future I still hope to merge my new 2-n wheels code where this would become more obvious.

We need to investigate why the calculated camber is reported incorrectly(same for left right). I had this fixed once but had to revert the code due to other issues.
Find all posts by this user
Quote this message in a reply
02-17-2012, 04:58 PM
Post: #7
 
I've pushed some code to get the camber right, needs testing though.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)