Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
last git update can't build
01-26-2012, 03:10 AM
Post: #1
last git update can't build
ray@rayQuadri:~/vdrift$ scons release=1 force_feedback=1
scons: Reading SConscript files ...
Checking for C++ header file asio.hpp... (cached) yes
Checking for C++ header file boost/bind.hpp... (cached) yes
Checking for C++ header file GL/gl.h... (cached) yes
Checking for C++ header file GL/glu.h... (cached) yes
Checking for C++ header file SDL/SDL.h... (cached) yes
Checking for C++ header file SDL/SDL_image.h... (cached) yes
Checking for C++ header file SDL/SDL_rotozoom.h... (cached) yes
Checking for C++ header file vorbis/vorbisfile.h... (cached) yes
Checking for C++ header file GL/glew.h... (cached) yes
Checking for C++ header file curl/curl.h... (cached) yes
Checking for C++ header file bullet/btBulletCollisionCommon.h... (cached) yes
Checking for C++ header file archive.h... (cached) yes
Checking for glDeleteSamplers(0, NULL) in C library GLEW... (cached) yes
scons: done reading SConscript files.
scons: Building targets ...
CPP build/ai.o
CPP build/car.o
CPP build/carcontrolmap_local.o
CPP build/cardynamics.o
CPP build/cartire.o
CPP build/dynamicsworld.o
CPP build/forcefeedback.o
CPP build/fracturebody.o
src/fracturebody.cpp: In member function ‘void FractureBody::setChildTransform(int, const btTransform&)’:
src/fracturebody.cpp:97:60: erreur: no matching function for call to ‘btCompoundShape::updateChildTransform(int&, const btTransform&, bool)’
src/fracturebody.cpp:97:60: note: candidate is:
/usr/include/bullet/BulletCollision/CollisionShapes/btCompoundShape.h:109:7: note: void btCompoundShape::updateChildTransform(int, const btTransform&)
/usr/include/bullet/BulletCollision/CollisionShapes/btCompoundShape.h:109:7: note: candidate expects 2 arguments, 3 provided
scons: *** [build/fracturebody.o] Error 1
scons: building terminated because of errors.
Find all posts by this user
Quote this message in a reply
01-26-2012, 04:08 AM
Post: #2
 
You need bullet > 2.77.
Find all posts by this user
Quote this message in a reply
01-26-2012, 07:35 AM
Post: #3
 
Ok built with bullet 2.79
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)