Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vdrift not start
09-25-2011, 02:18 PM
Post: #1
Vdrift not start
Process: VDrift [1190]
Path: /VDrift.app/Contents/MacOS/VDrift
Identifier: org.vdrift-team.vdrift
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [114]

Interval Since Last Report: 1829 sec
Crashes Since Last Report: 8
Per-App Interval Since Last Report: 0 sec
Per-App Crashes Since Last Report: 8

Date/Time: 2011-09-25 22:18:03.920 +0400
OS Version: Mac OS X 10.5.8 (9L31a)
Report Version: 6
Anonymous UUID: 5C9AD6A3-257B-474C-A2C3-5F6F6593B378

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/BulletCollision.framework/Versions/2.78/BulletCollision
Referenced from: /VDrift.app/Contents/MacOS/VDrift
Reason: no suitable image found. Did find:
/VDrift.app/Contents/MacOS/../Frameworks/BulletCollision.framework/Versions/2.78/BulletCollision: unknown required load command 0x80000022
/VDrift.app/Contents/MacOS/../Frameworks/BulletCollision.framework/Versions/2.78/BulletCollision: unknown required load command 0x80000022
/Library/Frameworks/BulletCollision.framework/Versions/2.78/BulletCollision: unknown required load command 0x80000022
Find all posts by this user
Quote this message in a reply
09-25-2011, 03:01 PM
Post: #2
 
Can you post the content of ~/Library/Preferences/VDrift/log.txt Thanks
Visit this user's website Find all posts by this user
Quote this message in a reply
09-25-2011, 05:00 PM
Post: #3
 
there won't be a log file since the crash happened before the binary started. probably the framework was compiled without 10.5 support?
Find all posts by this user
Quote this message in a reply
09-26-2011, 02:29 AM
Post: #4
 
in ~/Library/Preferences/ folder "Vdrift" not found.
may be it in other places? but i was lookin for everywhere on my iMac
Find all posts by this user
Quote this message in a reply
09-26-2011, 07:13 AM
Post: #5
 
as i said, dont bother, it wont be there.

i can confirm that the latest release doesn't run on 10.5

if you want your frameworks to work on 10.5. you either need to build them on 10.5. or set both deployment target and SDK to 10.5 in Xcode. building on the command line for previous versions is a bit more involved.
Find all posts by this user
Quote this message in a reply
09-26-2011, 05:32 PM
Post: #6
 
Ahh. And to use the 10.5 SDK you need xcode 3, which I don't have. Can anyone else compile a version for 10.5?
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)