Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bloom, motion blur, and ambient occlusion not doing anything
09-19-2011, 10:58 AM
Post: #1
Bloom, motion blur, and ambient occlusion not doing anything
It doesn't seem to be a compatibility issue.


Code:
INFO: Multi-processor system detected.  Run with -multithreaded argument to enable multithreading (EXPERIMENTAL).
INFO: Starting VDrift: development-full, Version: exported, O/S: Unix
INFO: Home directory: /home/eej
INFO: Settings file: /home/eej/.vdrift/VDrift.config
INFO: Data directory: /usr/local/share/games/vdrift/data
      DATA_DIR: /usr/local/share/games/vdrift/data
INFO: Temporary directory: /home/eej/.vdrift/tmp
INFO: Log file: /home/eej/.vdrift/log.txt
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
INFO: Display change was successful: 1440x900x32 24z fullscreen=1
INFO: GL Renderer: GeForce GT 240/PCI/SSE2
INFO: GL Vendor: NVIDIA Corporation
INFO: GL Version: 3.3.0 NVIDIA 270.41.06
INFO: Initialized GLEW 1.5.6
INFO: Loading /usr/local/share/games/vdrift/data/shaders/gl3/vdrift1.rhr...
INFO: Loaded /usr/local/share/games/vdrift/data/shaders/gl3/vdrift1.rhr
INFO: GL3 initialization successful
INFO: 0 joysticks found.
INFO: Loading car controls from: /home/eej/.vdrift/controls.config
INFO: Update status file /home/eej/.vdrift/updates.config will be created
INFO: Sound initialization information:
INFO: Obtained audio device:
      Frequency: 44100
      Format: 32784
      Bits per sample: 16
      Channels: 2
      Silence: 0
      Samples: 8290
      Size: 33160
      Sound initialization successful
Find all posts by this user
Quote this message in a reply
09-19-2011, 04:18 PM
Post: #2
 
I guess bloom and motion blur are just bugs that still haven't been fixed, but ambient occlusion used to work fine. What gives?
Find all posts by this user
Quote this message in a reply
09-19-2011, 04:53 PM
Post: #3
 
It seems reflections don't work either. Limited to environment maps.

What gives?
Find all posts by this user
Quote this message in a reply
09-20-2011, 11:14 PM
Post: #4
 
They haven't been reimplemented in the OpenGL3 renderer. You can run vdrift with the -gl2 argument to get the old OpenGL2 renderer.
Find all posts by this user
Quote this message in a reply
10-15-2011, 08:26 AM
Post: #5
 
I always had the same issues, and would like to know about this too. Bloom worked for me at some point, but now it doesn't again. Motion blur never did. Ambient occlusion... can't tell by eye.

I didn't know about the -gl2 argument. Thanks joevenzon! If it works on Windows I will try it too, and maybe that will get some shaders working for me.

[EDIT] -gl2 won't seem to work for me either Sad
Find all posts by this user
Quote this message in a reply
10-16-2011, 07:35 PM
Post: #6
 
The -gl2 argument is something I added when I made that post, so if you're running the last release you don't have it.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)