Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bug in cardynamics.cpp ComputeTireFrictionForce code
07-31-2011, 06:25 AM
Post: #1
Bug in cardynamics.cpp ComputeTireFrictionForce code
Code:
    btVector3 friction_force = tire[i].GetForce( normal_force, friction_coeff, camber_rads, angvel, lonvel, latvel );

GetForce 3rd argument is in radians while the function expects degrees.

Code:
btVector3 CARTIRE::GetForce (
    btScalar normal_force,                        // Fz, normal_force in N
    btScalar friction_coeff,                    // track surface friction scaling coefficient
    btScalar inclination,                        // camber, degrees
    btScalar ang_velocity,                        // rotational speed, rad/sec
    btScalar lon_velocity,                        // Vx
    btScalar lat_velocity )                        // Vy
{
...
}
Find all posts by this user
Quote this message in a reply
07-31-2011, 09:28 AM
Post: #2
 
And a few fixes later you'll be where I've been last year. Seriously, I'd prefer to see this fixes in a separate fork. With github this is mostly a matter of a few mouse clicks: In order to view links, you must have to reply to this thread.
Find all posts by this user
Quote this message in a reply
07-31-2011, 09:35 AM
Post: #3
 
NaN Wrote:And a few fixes later you'll be where I've been last year. Seriously, I'd prefer to see this fixes in a separate fork. With github this is mostly a matter of a few mouse clicks: In order to view links, you must have to reply to this thread.

No problem, I will continue on my own.
Find all posts by this user
Quote this message in a reply
07-31-2011, 09:51 AM
Post: #4
 
I didn't mean to turn you off. As your bug reports and fixes are actually confirming my own work. Fact is I've had this stuff(and some more) in trunk and it broke the cars and I haven't managed to fix them and people were pissed of.

I really hope to see your fork on github for me and others to try and test.
Find all posts by this user
Quote this message in a reply
07-31-2011, 12:06 PM
Post: #5
 
LBodnar Wrote:No problem, I will continue on my own.

Please feel free to continue to ask questions on the forum! I'd love to see these things get fixed too. :-)
Find all posts by this user
Quote this message in a reply
07-31-2011, 01:05 PM
Post: #6
 
Issue: In order to view links, you must have to reply to this thread.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)