Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
svn to git
07-01-2011, 06:18 PM,
svn to git

Before I used to svn update vdrift.

Now can you tell me right command ?
And can I deal with other branches ?

07-02-2011, 07:33 AM,
Clone into vdrift directory:
git clone git:// vdrift

For more stuff github has got some nice guides:
07-02-2011, 08:15 PM,
07-03-2011, 03:00 PM,
I made an attempt at updating the wiki with some instructions:
07-06-2011, 04:17 AM,
bullet is no more in source ?

Must I install bullet package, or download it from old svn ?
07-06-2011, 09:00 AM,
You can download bullet from or grab it from the old svn (which only has the files needed).
07-08-2011, 08:53 AM,
skankerror Wrote:bullet is no more in source ?

Must I install bullet package, or download it from old svn ?

You can install bullet as a normal lib Smile
07-11-2011, 04:32 AM,
After grabbing it from old svn, here's scons output :

Package bullet was not found in the pkg-config search path.
Perhaps you should add the directory containing `bullet.pc'
to the PKG_CONFIG_PATH environment variable
No package 'bullet' found
OSError: 'pkg-config bullet --libs --cflags' exited 1:
  File "/home/ray/vdrift/SConstruct", line 566:
    SConscript('src/SConscript', variant_dir='build', duplicate = 0)
  File "/usr/lib/scons/SCons/Script/", line 614:
    return method(*args, **kw)
  File "/usr/lib/scons/SCons/Script/", line 551:
    return _SConscript(self.fs, *files, **subst_kw)
  File "/usr/lib/scons/SCons/Script/", line 260:
    exec _file_ in call_stack[-1].globals
  File "/home/ray/vdrift/src/SConscript", line 347:
    local_env.ParseConfig('pkg-config bullet --libs --cflags')
  File "/usr/lib/scons/SCons/", line 1460:
    return function(self, self.backtick(command))
  File "/usr/lib/scons/SCons/", line 593:
    raise OSError("'%s' exited %d" % (command, status))
07-11-2011, 02:20 PM,
You shouldn't have to compile bullet from source:
sudo apt-get install libbullet-dev
07-13-2011, 03:57 PM,
Thanks now it works with libbullet-dev installed and bullet dir from old svn in vdrift dir.
07-15-2011, 10:37 AM,
I tried looking for bullet in the ubuntu natty package list and couldn't find it. It looks like it's in the "GetDeb games" PPA? Is that where you got it from or are you running a different ubuntu release?
07-15-2011, 04:38 PM,
I'm running maverick.

I installed one from get-deb repo (it's not really a ppa).

But you can find some packages in ppa. When searching I discovered a more recent package in cubit-team's ppa (2.78 ).

To find package in ppa jungle Y-PPA-Manager is a good tool (he's in get-deb).
07-15-2011, 06:59 PM,
I've been surprised that they(buntu) don't have a official bullet package, am also using 2.77-1~getdeb1 version.
07-17-2011, 01:04 PM,
OK, so I installed the getdeb bullet package (2.77-1~getdeb1), but SCons is failing when checking for the btCollisionCommon.h header. Here's what my config.log looks like:

scons: Configure: Checking for C++ header file bullet/btBulletCollisionCommon.h...
.sconf_temp/conftest_10.cpp <-
  |#include "bullet/btBulletCollisionCommon.h"
        CPP .sconf_temp/conftest_10.o
In file included from /usr/include/bullet/btBulletCollisionCommon.h:22:0,
                 from .sconf_temp/conftest_10.cpp:2:
/usr/include/bullet/BulletCollision/CollisionDispatch/btCollisionWorld.h:74:34: fatal error: LinearMath/btVector3.h: No such file or directory
compilation terminated.
scons: Configure: no

It looks to me like /usr/include/bullet needs to be added as an include path.

joe@joe02:~/code/VDrift$ pkg-config bullet --libs --cflags
-I/usr/include/bullet  -lBulletSoftBody -lBulletDynamics -lBulletCollision -lLinearMath

In src/SConscript we have a line:
local_env.ParseConfig('pkg-config bullet --libs --cflags')

The conf.CheckCXXHeader(header) stuff happens in SConstruct with an environment that doesn't have the bullet paths pulled in yet. If I move the ParseConfig into SConstruct just before the check_headers stuff, everything works for me. I'm not sure how well that will work for other systems, in particular Windows msys builds, but it seems like the best way to build on windows these days is with code blocks anyway.

I went ahead and pushed that change:

My first github commit!

Let me know if that breaks stuff for anyone.

Forum Jump:

Users browsing this thread: 1 Guest(s)