Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vdrift crash while loading
05-07-2011, 07:24 AM,
Vdrift crash while loading
Hi folks

INFO: Multi-processor system detected. Run with -multithreaded argument to enable multithreading (EXPERIMENTAL).
INFO: Starting VDrift: 2011-04-26-full, Version: , O/S: Unix-like
INFO: Home directory: /home/hamed
INFO: Settings file: /home/hamed/.vdrift/VDrift.config
INFO: Data directory: data
DATA_DIR: /usr/share/vdrift/data
INFO: Log file: /home/hamed/.vdrift/log.txt
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Enabling antialiasing: 4X
INFO: Display change was successful: 1680x1050x32 24z fullscreen=1
INFO: Video card information:
Vendor: NVIDIA Corporation
Renderer: GeForce GTS 250/PCI/SSE2
Version: 3.3.0 NVIDIA 270.41.06
Maximum texture size: 8192
Maximum varying floats: 60
Using GLEW 1.5.8
INFO: Maximum color attachments: 8
INFO: Maximum draw buffers (1 required): 8
INFO: Texture units: 4 full, 32 partial
INFO: Loaded shader package simple
INFO: Loaded shader package simple, variant simple_premult
INFO: Loaded shader package simple, variant simple_gamma_premult
INFO: Loaded shader package simple, variant simple_gamma
INFO: Loaded shader package simple, variant simplecar
INFO: Loaded shader package logluminance
INFO: Loaded shader package logluminance, variant logluminance_tiny
INFO: Loaded shader package tonemap
INFO: Loaded shader package gbufferfill
INFO: Loaded shader package gbufferfill, variant gbufferfillcar
INFO: Loaded shader package lightaccumulate, variant lightaccumulate_initial
INFO: Loaded shader package lightaccumulate, variant lightaccumulate_omni
INFO: Loaded shader package depthgen
INFO: Loaded shader package depthgen, variant depthgennoalpha
INFO: Loaded shader package distancefield
INFO: Loaded shader package deferredskybox
INFO: Loaded shader package deferredskyboxblend
INFO: Loaded shader package softparticle
INFO: Loaded shader package ppdepthadjust
INFO: Loaded shader package ppdepthadjust, variant ppcopy
INFO: Loaded shader package ppdepthadjust, variant ppcopy_gamma
INFO: Loaded shader package deferredshadows
INFO: Loaded shader package ssao
INFO: Loaded shader package ssao_blur
INFO: Successfully enabled shaders
INFO: Initialized render output: full_scene_depth (FBO)
INFO: Initialized render output: full_scene_color (FBO)
INFO: Initialized render output: normal_xy (FBO)
INFO: Initialized render output: material_properties (FBO)
INFO: Initialized render output: diffuse_albedo (FBO)
INFO: Initialized render output: log_luminance (FBO)
INFO: Initialized render output: log_luminance_tiny (FBO)
INFO: Initialized render output: ssao1 (FBO)
INFO: Initialized render output: ssao2 (FBO)
INFO: Initialized render output: reflection_cube (FBO)
INFO: Initialized render output: shadow_depths_near (FBO)
INFO: Initialized render output: shadow_depths_medium (FBO)
INFO: Maximum anisotropy: 16
INFO: 1 joystick found:
INFO: 0. Microsoft Wired Keyboard 600
INFO: Loading car controls from: /home/hamed/.vdrift/controls.config
INFO: Sound initialization information:
INFO: Obtained audio device:
Frequency: 44100
Format: 32784
Bits per sample: 16
Channels: 2
Silence: 0
Samples: 1024
Size: 4096
Sound initialization successful
INFO: Loaded fonts successfully
INFO: Loaded GUI successfully
INFO: Loading track from path: data/tracks/paulricard88
INFO: Can't find surfaces configfile: data/tracks/paulricard88/surfaces.txt
INFO: No Surfaces File. Continuing with standard surfaces
INFO: Track timing sectors: 2
INFO: Track object list has 16 params per object, expected 17, this is fine, continuing
INFO: Collision objects: 1
INFO: Car loading was successful: XS
vdrift: include/cartelemetry.h:63: void CARTELEMETRY::Update(CARTELEMETRY::T): Assertion `file' failed.
SIGABRT detected, releasing the mouse
/usr/bin/vdrift: line 3: 15186 Aborted ./bin/vdrift "$@"

Any idea?
05-07-2011, 01:28 PM,
A bit more info would be great.

Where do you have it from? Compiled by yourself? Revision?
05-07-2011, 05:58 PM,
NaN Wrote:A bit more info would be great.

Where do you have it from? Compiled by yourself? Revision?

Last stable version from packman in opensuse 11.4 64bit
05-07-2011, 06:12 PM,
Can you please report the bug to packman (packman(at), thanks.
05-08-2011, 11:15 AM,
getting the dev version going on ubuntu wasn't that difficult, it's probably pretty easy with suse too.

a little trickier since the glew version got higher than ubuntu has(had?) in it's repo. but should be pretty do-able, if it's even still an issue.
is a good place to start after you got it, it's mostly a matter of synaptic-ing a new dependency each time you get a compile error.
05-11-2011, 01:38 AM,
and a few days after i mention this i upgrade to the latest ubuntu and things stop compiling or executing.

./vdrift3115: symbol lookup error: ./vdrift3115: undefined symbol: __glewSamplerParameteri

so this is probably a glew version error like before, but the repo from before has the same version that i have now

not entirely sure what this version number means, seems to imply that it's being listed as 1.5.7 but is, in reality 1.5.2...which makes me ask "why would anyone want to be such a chump to list the wrong version number" ...but then again ubuntu has certainly devolved their interface in the past version (gnome was at least use-able) why not devolve everything else too.
05-11-2011, 04:25 PM,
1.5.7 breaks their unity thingy.
05-12-2011, 02:24 AM,
ahh, that's upsetting.

so even if don't want to use unity it still finds a way to cramp my style. perhaps it is time to change distros.
05-12-2011, 03:02 PM,
ok, so i got the glew 1.6.0 tar.gz (tried the zip first but that doesn't contain the stuff to build on linux), make installed it. and then recompiled latest svn vdrift (3118) and all worked well.

just to check, i logged into unity, and found no issues at all. it launched like normal, and seemed to suck err "work" as normal. synaptic's versioning for glew is wrong now, but i don't anticipate that being much of an issue.

Forum Jump:

Users browsing this thread: 1 Guest(s)