Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
bug in r3057
02-15-2011, 06:56 AM
Post: #1
bug in r3057
Hi, when start single race at Montreal with F102 against 3 others F102, here's problem just after the start :

Code:
vdrift: src/cardynamics.cpp:1220: btVector3 CARDYNAMICS::ComputeTireFrictionForce(int, btScalar, btScalar, btScalar, btVector3&, const btQuaternion&): Assertion `Aproj.length() > 0.001' failed.
SIGABRT detected, releasing the mouse
Abandon

This happens sometimes on other tracks, but this always happens at Montreal.
Find all posts by this user
Quote this message in a reply
02-15-2011, 07:01 AM
Post: #2
 
Code:
vdrift: src/cardynamics.cpp:1224: btVector3 CARDYNAMICS::ComputeTireFrictionForce(int, btScalar, btScalar, btScalar, btVector3&, const btQuaternion&): Assertion `!isnan ( camber_rads )' failed.
SIGABRT detected, releasing the mouse
Abandon

Same cars in Monza.
Find all posts by this user
Quote this message in a reply
02-15-2011, 12:36 PM
Post: #3
 
Thanks. Fixed in 3059.
Find all posts by this user
Quote this message in a reply
02-16-2011, 08:56 AM
Post: #4
 
Code:
vdrift: src/cardynamics.cpp:1224: btVector3 CARDYNAMICS::ComputeTireFrictionForce(int, btScalar, btScalar, btScalar, btVector3&, const btQuaternion&): Assertion `!isnan ( camber_rads )' failed.
SIGABRT detected, releasing the mouse
Abandon

360 in Nurburgring r3060.
Find all posts by this user
Quote this message in a reply
02-16-2011, 11:07 AM
Post: #5
 
Haven't been able to reproduce it. It can be fixed by clamping the value. But I still would like to know when/where on the track it is triggered(screenshot would be great if possible).

And thanks again for reporting the bug.
Find all posts by this user
Quote this message in a reply
02-16-2011, 12:27 PM
Post: #6
 
In fact this happens with several cars on many tracks. It seems this happens especially when I get off road on sand but I'll try to be more precise about facts.

Screenshot is impossible because when this happens vdrift closes, and I can't reproduce this bug.
Find all posts by this user
Quote this message in a reply
02-16-2011, 12:52 PM
Post: #7
 
It just happened in mulsanne curve at Le Mans with F1-02.

I was too speed at the beginning of the curve, got off road on the sand with huge speed, trying to turn on the right to get on the road.

For me this often happens on sand with great speed, car out of control, car going on a direction and wheels on the opposite. Lot of strenght on the wheels, maybe my white tyres just explode ?? :?
Find all posts by this user
Quote this message in a reply
02-16-2011, 01:13 PM
Post: #8
 
Quote:got off road
Thanks, I've got an idea where to look into.
Find all posts by this user
Quote this message in a reply
02-16-2011, 02:57 PM
Post: #9
 
It just happened when curving good, on the road... at imola with F1

So the only recurrent point is when turning.
Find all posts by this user
Quote this message in a reply
02-16-2011, 02:58 PM
Post: #10
 
Haven't been able to trigger it yet. Will try harder, lol.
Find all posts by this user
Quote this message in a reply
02-17-2011, 12:14 PM
Post: #11
 
Did you change something in r3061 because I played 2 hours without any bug ?
Find all posts by this user
Quote this message in a reply
02-17-2011, 01:33 PM
Post: #12
 
Applied a fix. Looks like it was a numerical precision issue.

Can you try the original tire texture with the latest revision?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)