Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
VDrift doesn't start no matter what
01-09-2011, 12:59 AM,
VDrift doesn't start no matter what
I am very knew to vdrift and ubuntu 10.04. My problem is that when I run vdrift, it will show a black screen for a 1/2 second, then disappear. I've searched everywhere on the internet to find a solution, but nothing worked for me. Please help me get vdrift to work. If possible, explain in easy to follow steps. I'll be happy to give any more needed info, but I probably wont know what you will be talking about if it is not explained.
01-09-2011, 01:06 AM,
I forgot to mention that when i typed "vdrift" into terminal, it came up with this:

INFO: Multi-processor system detected. Run with -multithreaded argument to enable multithreading (EXPERIMENTAL).
INFO: Starting VDrift: 2010-07-24-full, Version: , O/S: Unix-like
INFO: Home directory: /home/dan
INFO: Settings file: /home/dan/.vdrift/VDrift.config (does not exist, will be created)
INFO: Data directory: /usr/share/games/vdrift/data
DATA_DIR: /usr/share/games/vdrift/data
INFO: Log file: /home/dan/.vdrift/log.txt
INFO: The last VDrift startup was unsuccessful.
Settings have been set to failsafe defaults.
Your original VDrift.config file was backed up to VDrift.config.backup
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
INFO: Display change was successful: 800x600x16 16z fullscreen=0
ERROR: You don't have an NVIDIA or ATI/AMD card. This game may not run correctly or at all.
INFO: Video card information:
Vendor: Advanced Micro Devices, Inc.
Renderer: Mesa DRI R600 (RS780 9612) 20090101 x86/MMX+/3DNow!+/SSE2 TCL DRI2
Version: 1.5 Mesa 7.7.1
Maximum texture size: 4096
Maximum varying floats: 0
Using GLEW 1.5.2
INFO: Your video card doesn't support framebuffer objects. Disabling shaders.
ERROR: OpenGL error "invalid enumerant" during: Cubemap ID generation
Segmentation fault
01-09-2011, 02:51 PM,
Quote:ERROR: OpenGL error "invalid enumerant" during: Cubemap ID generation
Looks like your graphics driver gives an invalid enumerant error at texture generation "glGenTextures(1, &new_handle);". Are you able to run any other 3d(opengl) games?

Have you considered trying the proprietary graphics driver from AMD?
01-09-2011, 06:38 PM,
I dont really know what you mean, but I can play games like assault cube, nexuiz, and tremulous. For the proprietary driver, if I am correct, I activated it and then when I tried running vdrift nothing would happen. Not even a black screen that would disappear would show. I could be wrong though. Please give some sort of guide to follow if this doesn't sound right.
01-09-2011, 07:21 PM,
Quote:I activated it and then when I tried running vdrift nothing would happen.
To check the driver run fglrxinfo from terminal. It should report the driver version and some other stuff.

Are you getting any output when running vdrift from terminal with the amd driver?
01-09-2011, 07:33 PM,
When i checked the driver in terminal, i got:

fglrxinfo: command not found

Also, what do you mean by: Are you getting any output when running vdrift from terminal with the amd driver?

Like i said before, i am not good with vdrift or ubuntu 10.04. I do not know a lot about codes, data, or anythings else of the sort. Please try to explain a little easier.
01-09-2011, 07:52 PM,
If you have the fglrx driver installed you should be able to call fglrxinfo.

lsmod | grep fglrx
grep fglrx /var/log/Xorg.0.log

Installation guide here:
01-09-2011, 08:04 PM,
Can't I just install it again using the buttons System, administration, hardware drivers...
01-09-2011, 08:13 PM,
I feel really dumb. All I had to do when I had the driver before i uninstalled it was restart my computer. Now it works. Thanks for your help.
01-10-2011, 05:00 PM,
I am extremely confused now. At first when I started trying to get VDrift, I couldn't find one or it wouldn't work so I saw somewhere that I could get synaptic to find it. I got VDrift using that way. Now when I play, I just thought maybe the graphics were terrible and there are no modes besides practice and single race. Then I just started looking at images and videos and I'm stunned at the graphics and new things it actually has. Please help me get the newest version for Ubuntu 10.04!!!!!!
01-10-2011, 05:53 PM,
Click the Ubuntu link in the downloads box at the top of the main page. The wiki is very helpful - start at
01-10-2011, 07:14 PM,
It doesn't help with the installation and i don't exactly know what to do.
01-10-2011, 07:22 PM,
If you type "vdrift" into terminal you should get 2010-07-24-full. This is the latest release.

Quote:maybe the graphics were terrible and there are no modes besides practice and single race
There are no other modes besides practice and single race. The graphics will look terrible because the shaders are disabled. Have a look at Options -> Display -> Advanced settings in the game menu.

Your problem will be that you are running VDrift on an low level integrated graphics chip(RS780). It is way too slow to run all the fancy graphics settings to get VDrift look good.
01-10-2011, 07:31 PM,
It's not the same thing i swear because mine doesn't have 28 cars, or 19 tracks. look here:
01-10-2011, 07:39 PM,
Tracks are here:

Cars are here:

The complete vdrift-data(Warning! It is huge):

Download the tarballs and extract them into vdrift data directory.

Forum Jump:

Users browsing this thread: 1 Guest(s)