Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
windows vista home premium (32) v drift not loading
07-15-2010, 02:58 PM,
#16
 
You've hit a bug in the latest code(will fix it asap). This one should work(finally). http://www.file-upload.net/download-2674...t.zip.html
Reply
07-19-2010, 04:51 AM,
#17
unable to start vdrift
Hi , I have the same problem. I've tried your patches, but it keeps on closing the window without starting the game. it opens 2 dos windows very fast and that's it.

here is my log.txt
====
INFO: Starting VDrift: 2010-03-28-full, Version: 2650M, O/S: Windows
INFO: Home directory: C:\Documents and Settings\JORGE
INFO: Settings file: C:\Documents and Settings\JORGE\My Documents\My Games\VDrift/VDrift.config
INFO: Data directory: data
INFO: Log file: C:\Documents and Settings\JORGE\My Documents\My Games\VDrift/log.txt
INFO: The last VDrift startup was unsuccessful.
Settings have been set to failsafe defaults.
Your original VDrift.config file was backed up to VDrift.config.backup
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
INFO: Display change was successful: 800x600x16 16z fullscreen=0
INFO: Video card information:
Vendor: NVIDIA Corporation
Renderer: GeForce FX 5600/AGP/SSE2
Version: 1.5.2
Maximum texture size: 4096
Maximum varying floats: 32
Using GLEW 1.5.4
INFO: Your video card doesn't support framebuffer objects. Disabling shaders.
===

thanks for your help
Reply
07-19-2010, 09:52 AM,
#18
 
Jormar try this debug build. Please run it from the command promt to see if vdrift returns something on exit/crash. Additionally check if there are a stdout.txt, stderr.txt in the game folder. Thanks.

vdrift r2833 debug: http://www.file-upload.net/download-2683...t.zip.html
Reply
07-20-2010, 12:51 PM,
#19
 
Hi NaN,

the file that I get is still v2650M, but you mentioned r2833 , and I still have the same problem. the log is the same.

file name : Vdrift.exe
size: 40.7 MB (42,734,759 bytes)
date: Mon July 19, 2010, 3:38:08 PM

XP Pro 32bit SP2 2048MB ram

==== stdout.txt ====
INFO: Starting VDrift: 2010-03-28-full, Version: 2650M, O/S: Windows
INFO: Home directory: C:\Documents and Settings\JORGE
INFO: Settings file: C:\Documents and Settings\JORGE\My Documents\My Games\VDrift/VDrift.config
INFO: Data directory: data
INFO: Log file: C:\Documents and Settings\JORGE\My Documents\My Games\VDrift/log.txt
INFO: The last VDrift startup was unsuccessful.
Settings have been set to failsafe defaults.
Your original VDrift.config file was backed up to VDrift.config.backup
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
INFO: Display change was successful: 800x600x16 16z fullscreen=0
INFO: Video card information:
Vendor: NVIDIA Corporation
Renderer: GeForce FX 5600/AGP/SSE2
Version: 1.5.2
Maximum texture size: 4096
Maximum varying floats: 32
Using GLEW 1.5.4
INFO: Your video card doesn't support framebuffer objects. Disabling shaders.
======

I'll make another test and I'll be sending the log in another msg. I'll use my Win 7 ultimate on the same PC just to see if there is a difference.
Reply
07-20-2010, 01:02 PM,
#20
 
Ignore the v2650M identifier. I've been too lazy to update it. Have you been running vdrift from command promt(stderr.txt, stdout.txt)?
Reply
07-20-2010, 01:06 PM,
#21
 
Hi Nan, ok I've tested under Win 7 Ultimate with same hardware, and it works OK !!!

here is the log

==== stdout.txt ====
INFO: Starting VDrift: 2010-03-28-full, Version: 2650M, O/S: Windows
INFO: Home directory: G:\Users\ENGLISH
INFO: Settings file: G:\Users\ENGLISH\My Documents\My Games\VDrift/VDrift.config
INFO: Data directory: data
INFO: Log file: G:\Users\ENGLISH\My Documents\My Games\VDrift/log.txt
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
INFO: Display change was successful: 800x600x16 24z fullscreen=1
INFO: Video card information:
Vendor: NVIDIA Corporation
Renderer: GeForce FX 5600/AGP/SSE2
Version: 2.1.0
Maximum texture size: 4096
Maximum varying floats: 32
Using GLEW 1.5.4
INFO: Your video card doesn't support framebuffer objects. Disabling shaders.
INFO: Maximum anisotropy: 8
INFO: 1 joystick found:
INFO: 0. Microsoft PC-joystick driver
INFO: Loading car controls from: G:\Users\ENGLISH\My Documents\My Games\VDrift/controls.config
INFO: Sound initialization information:
INFO: Obtained audio device:
Frequency: 44100
Format: 32784
Bits per sample: 16
Channels: 2
Silence: 0
Samples: 2048
Size: 8192
Sound initialization successful
INFO: Loaded fonts successfully
INFO: Loaded GUI successfully
INFO: Loading track from path: data/tracks/paulricard88
INFO: Can't find surfaces configfile: data/tracks/paulricard88/surfaces.txt
INFO: No Surfaces File. Continuing with standard surfaces
INFO: Track timing sectors: 2
INFO: Track object list has 16 params per object, expected 17, this is fine, continuing
INFO: Collision objects: 1
INFO: No car brake texture exists, continuing without one
INFO: No car reverse light texture exists, continuing without one
INFO: No car interior model exists, continuing without one
INFO: No car glass model exists, continuing without one
INFO: Car loading was successful: F1-02
INFO: Loading track from path: data/tracks/paulricard88
INFO: Can't find surfaces configfile: data/tracks/paulricard88/surfaces.txt
INFO: No Surfaces File. Continuing with standard surfaces
INFO: Track timing sectors: 2
INFO: Track object list has 16 params per object, expected 17, this is fine, continuing
INFO: Collision objects: 1
INFO: No car brake texture exists, continuing without one
INFO: No car reverse light texture exists, continuing without one
INFO: No car interior model exists, continuing without one
INFO: No car glass model exists, continuing without one
INFO: Car loading was successful: F1-02
INFO: Got quit message from GUI. Shutting down...
INFO: Shutting down...
INFO: Exiting
======

at least it starts the game, during the game if I crash it becomes impossible to continue as I only see a blank white screen ( dust/smoke??)

thanks for your help

under XP it's a not go and no error message.

BTW I'm using the xp installation, just booting under win 7 and starting the vdrift.exe under win 7 instead of xp. so same files, same HW, just different OS
Reply
07-20-2010, 01:12 PM,
#22
 
Maybe a graphics driver issue(Win7 vs WinXP).

The white stuff are the soft particles with shaders disabled. Quite ugly I know. I guess we should add an option to disable smoke.
Reply
07-20-2010, 02:10 PM,
#23
 
Hi Nan,
I've updated my Nvidia drivers to 169.21 and now I can play the game in XP.
here is the log
===stdout.txt===
INFO: Starting VDrift: 2010-03-28-full, Version: 2650M, O/S: Windows
INFO: Home directory: C:\Documents and Settings\JORGE
INFO: Settings file: C:\Documents and Settings\JORGE\My Documents\My Games\VDrift/VDrift.config
INFO: Data directory: data
INFO: Log file: C:\Documents and Settings\JORGE\My Documents\My Games\VDrift/log.txt
INFO: The last VDrift startup was unsuccessful.
Settings have been set to failsafe defaults.
Your original VDrift.config file was backed up to VDrift.config.backup
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
INFO: Display change was successful: 800x600x16 16z fullscreen=0
INFO: Video card information:
Vendor: NVIDIA Corporation
Renderer: GeForce FX 5600/AGP/SSE2
Version: 2.1.2
Maximum texture size: 4096
Maximum varying floats: 32
Using GLEW 1.5.4
INFO: Your video card doesn't support framebuffer objects. Disabling shaders.
INFO: Maximum anisotropy: 8
INFO: 0 joysticks found.
INFO: Loading car controls from: C:\Documents and Settings\JORGE\My Documents\My Games\VDrift/controls.config
INFO: Car control file C:\Documents and Settings\JORGE\My Documents\My Games\VDrift/controls.config doesn't exist; using defaults
INFO: Sound initialization information:
INFO: Obtained audio device:
Frequency: 44100
Format: 32784
Bits per sample: 16
Channels: 2
Silence: 0
Samples: 2048
Size: 8192
Sound initialization successful
INFO: Loaded fonts successfully
INFO: Loaded GUI successfully
INFO: Loading track from path: data/tracks/paulricard88
INFO: Can't find surfaces configfile: data/tracks/paulricard88/surfaces.txt
INFO: No Surfaces File. Continuing with standard surfaces
INFO: Track timing sectors: 2
INFO: Track object list has 16 params per object, expected 17, this is fine, continuing
INFO: Collision objects: 1
INFO: Car loading was successful: XS
INFO: Got quit message from GUI. Shutting down...
INFO: Shutting down...
INFO: Exiting
=======


some surfaces are missing, is that the reason I see all that white smoke ?

thanks

Jorge
Reply
07-20-2010, 10:53 PM,
#24
 
The white smoke is due to a different bug that only shows up with shaders off (with your GFX card VDrift runs with shaders off). It'll be fixed for the next release.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)