Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't quit
10-29-2009, 09:04 AM,
Can't quit

I'm on Ubuntu Karmic RC1 trying out the svn-version (the one from yesterday, guess it was 2548). Played it some time - nice! But as I wanted to quit, vdrift won't let me. I had to "kill -9 vdrift"!

My system's a AMD Athlon X2 4850, GPU's a integrated Radeon HD3200.
10-29-2009, 09:10 AM,
Same problem with svn 2549.
10-30-2009, 10:20 AM,
I can't reproduce this. Can you post your ~/.vdrift/log.txt file?

If you run in a window can you close it by closing the window?
10-30-2009, 11:56 AM,
Of course I can post log.txt, but you won't see anything suspicious...

INFO: Multi-processor system detected.  Run with -multithreaded argument to enable multithreading (EXPERIMENTAL).
INFO: Starting VDrift: 2009-10-29-full, Version: 2549, O/S: Unix-like
INFO: Home directory: /home/mitsch
INFO: Settings file: /home/mitsch/.vdrift/VDrift.config
INFO: Data directory: /usr/local/share/games/vdrift/data
      DATA_DIR: /usr/local/share/games/vdrift/data
INFO: Log file: /home/mitsch/.vdrift/log.txt
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Disabling antialiasing
INFO: Display change was successful: 800x600x16 24z fullscreen=0
ERROR: You don't have an NVIDIA or ATI/AMD card.  This game may not run correctly or at all.
INFO: Video card information:
      Vendor: Mesa Project
      Renderer: Software Rasterizer
      Version: 2.1 Mesa 7.6
      Maximum texture size: 4096
      Using GLEW 1.5.1
INFO: Disabling shaders
INFO: Maximum anisotropy: 0
INFO: 0 joysticks found.
INFO: Loading car controls from: /home/mitsch/.vdrift/controls.config
INFO: Sound initialization information:
INFO: Obtained audio device:
      Frequency: 44100
      Format: 32784
      Bits per sample: 16
      Channels: 2
      Silence: 0
      Samples: 512
      Size: 2048
      Sound initialization successful
INFO: Loaded fonts successfully
INFO: Loaded GUI successfully
INFO: Got quit message from GUI.  Shutting down...
INFO: Shutting down...
When I run in terminal and after I killed the window (won't close with pressing the X) I get an additional line, saying: "killed". That's all!

Guess it has something to do with the SDL-version of karmic. Yesterday I tried some other games: Teeworlds and luola. Both depend on libsdl and both refused to quit. So, I guess you can do nothing about it. I'm trying to reinstall SDL and hope for the best.

Thank you, anyway... Smile

PS: Don't mind about the software-rasterizer. I changed to the opensource-driver instead of using fglrx...
10-30-2009, 12:42 PM,
Reinstalled all SDL-Libraries and I have no problem any more. Sorry for making a fuzz.


Forum Jump:

Users browsing this thread: 1 Guest(s)