Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mac os x port
11-04-2005, 02:41 PM,
mac os x port
abs1nth Wrote:
abs1nth Wrote:i'm currently uploading the binary
get it here while it's hot:****
grrrr taken offlinesome last minute problems ;(EDIT: already released
11-04-2005, 03:36 PM,
mac os x port
abs1nth Wrote:some last minute problems ;(
lol actually this is the strangest bug i've ever seen:vdrift doesn't work (*) when the path to it's data files is exactly 32 chars!i discovered it only because i downloaded my binary stored it in "/Applications/_Games/vdrift/" and tried it out once more.... i was stumbled that it worked in EVERY other position on my filesystem, but not in this ... turns out "/Applications/_Games/vdrift/data" is exactly 32 chars and it also doesn't work in "/12345678901234567890123456/data"....does anybody have a clue where this bug comes from?does it also occur on linux/windows?should the mac binary release be delayed? seems kinda like a seldom triggered bug :wink:* displays the same symptoms as when it doesn't find it's data files - that is hanging at a black screen with two white bars at the left top
11-04-2005, 04:08 PM,
mac os x port
I'd say let's go ahead with the release. We can add that as a release note in the article about it.That is a very strange bug indeed, maybe you could try adding a cout somewhere to check the value of the path as the game sees it, and make sure there's not something missing. Sometimes we use an array of chars to process paths or something so it might be that one of those arrays is too small.
11-04-2005, 04:12 PM,
mac os x port
thelusiv Wrote:I'd say let's go ahead with the release. We can add that as a release note in the article about it.
ok the release is there is a part of the readme, you may note that in the release notes in addition to those path issue:"This release has been built on Mac OS X "Tiger" 10.4 but should work on earlier releases, but you may need to install OpenAL: following mac specific bugs are known:• sound doesn't work • crashes sometimes• on-the-fly resolution-switching doesn't work"
11-05-2005, 01:57 AM,
mac os x port
I have posted this on the VDrift SourceForge project under the file releases.
11-05-2005, 06:12 PM,
mac os x port
Good news, everyone!since fmod compilation works again in svn i tried it out and compiling on osx against fmod actually produces a great sounding binary :wink: (i.e. sound works now)i commited the neccesary fixes to svn...btw. is much easier to drive with sound...

Forum Jump:

Users browsing this thread: 1 Guest(s)