The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 895 - File: showthread.php PHP 7.2.24 (Linux)
File Line Function
/showthread.php 895 errorHandler->error




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
conflicting libpng versions
12-16-2010, 12:01 PM,
#1
conflicting libpng versions
I installed vdrift under Slackware 13.1 / 2.6.33.4-smp. The install worked fine, but when I try to start the game I get this error message:

INFO: Your video card doesn't support framebuffer objects. Disabling shaders.
libpng warning: Application was compiled with png.h from libpng-1.4.2
libpng warning: Application is running with png.c from libpng-1.2.43
libpng error: Incompatible libpng version in application and library
ERROR: Error loading texture file: /usr/local/share/games/vdrift/data/textures/weather/cubereflection-nosun.png

I don' t really know how to sort this out. I could off course uninstall libpng-1.4.2 and then reinstall vdrift, but I guess that messes up things.
Could I force vdrift to use its own libpng version during install, or force it to use it when in starts up??

Thanks in advance for any help

regards

Emile
Reply


Messages In This Thread
conflicting libpng versions - by pixie666 - 12-16-2010, 12:01 PM
[No subject] - by thelusiv - 12-16-2010, 12:06 PM
[No subject] - by pixie666 - 12-16-2010, 01:25 PM
[No subject] - by thelusiv - 12-16-2010, 05:10 PM
[No subject] - by fudje - 12-16-2010, 05:26 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)