Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Release very soon
03-17-2007, 11:46 AM,
rookie1 Wrote:I've tried the new package and the installation is successful. I think 2 texture files were left out however,


These are the dots shown on the track map.

i just fixed the SConscript file. they should be installed now.

03-17-2007, 01:08 PM,
Just to give everyone an update, the release is probably going to be Monday or Tuesday.
03-17-2007, 01:22 PM,
joevenzon Wrote:Just to give everyone an update, the release is probably going to be Monday or Tuesday.

Great, great, great news!
Thank u so much.
03-18-2007, 06:44 PM,
I compiled the SVN 1625 for OS X, pretty sweet new cars ant tracks. Can't wait to see the improvements in the release, it'll be sweet. Getting rid of the "career" option was great. Love the new menu, theme and all.
03-19-2007, 01:52 AM,
Yeah sorry for not letting anyone know, but I've been at Road Atlanta all weekend (yes, the track in the game). If you're wondering, no, the track in the game doesn't quite do the real one justice...I'll go into what could be improved later. Anyway I spent the weekend working at driver flagging stations on the turns. I had a blast and today I got to drive a friend's car around the track for a couple of touring laps (less than 60 mph, but still fun, esp. through the esses). What a cool track!

Anyway, since the new package seems to be working, I'll finish up the loose ends tomorrow and finally get the release out. I really tried to finish before I left but didn't quite have time. However I did put together release notes and I think I have figured out how to statically link OpenAL, ALUT, and SDL_gfx (because those don't have a "skeleton" for, OpenAL and ALUT are a pain to install and get the right version). The last file I linked above I actually updated once more after that post with some static linking. Tomorrow the release should go out with all 3 (after someone besides me, not running Ubuntu, tests it out Wink )

abs1nth: What I had intended for you to do was to just empty the definitions.h file when you build, and continue using config_mac.h as before.

Really though, I wish we could use SCons on every platform so that things like this would be more straightforward. I bet XCode could even be set up to run the build using SCons commands, even using scons-local which can be distributed with the build setup (we already include it with every release), so people wanting to compile don't have to go through the extra step of installing SCons on their systems. That is, after all, one of the reasons I wanted to use SCons in the first place, it is very cross-platform compatible. If I had a machine to run OS X on, I would set it up myself, I bet it would take little work to add Apple support to the build setup (and Windows too, for that matter).
03-19-2007, 12:00 PM,
With the latest autopackage, I get the following error when running it:

FAIL:Install the package with the command 'package install' instead.

When I run "package install VDrift..." I get:

FAIL:The action 'install' is unknown. Run 'package --help' to see a list of possible actions.

Perhaps the upload was corrupt?
03-20-2007, 03:15 AM,
The problem on your end Joe is that you need newer Autopackage tools, and I guess that it's not really doing a good job of seeing this and updating itself. I'm trying to talk to the Autopackage folks but they've shut down their forums because of spam and no one is answering in IRC. I guess I'll make a mailing list post...I just can't find anything on the web site, wiki, or anything else explaining how to upgrade it besides just reinstalling it - which is missing the point of Autopackage, it's supposed to automatically install itself. I'll see what I can come up with. I have successfully tested the static compilation of OpenAL, ALUT and SDL_gfx. The package installs just fine, and VDrift runs on my system even after I uninstall all 3 of those libraries. Here's a link to the latest testing package: (12MB) right-click, save as
03-20-2007, 04:01 AM,
Okay, but why did your last autopackage work (more or less), while the new one immediately fails? Is this latest one working for everyone else?
03-20-2007, 04:12 AM,
Well, it seems to be because I changed the autopackage "target version" to 1.2 instead of 1.0. That caused the package to be built a little differently. One change was the different name, another was forcing users to use "package install" instead of installing directly. I don't think they thought that out very well though, because they have sort of broken backwards compatibility. Maybe I should just stick with the 1.0 spec, but I think the 1.2 spec is probably better since most people probably will not have installed any autopackages before, anyway. Either way I'd like to know how to really fix it, so we can use the new stuff but also include instructions on how to update the autopackage stuff for folks who need to. Sadly, the autopackage docs are dreadfully out of date. I've just joined the mailing list, since I didn't get any help in IRC, and making a post before I go to sleep tonight...
03-20-2007, 08:54 AM,
I have no problem installing the 2007-03-17 version. It also automatically updated my autopackage to 1.2.1. The 2007-03-20 version gives me no problem either. I guess it's because I'm already running autopackage 1.2.1 by now.
03-20-2007, 12:05 PM,
Ahah... my package executable (/usr/bin/package) is a Tcl built-in command. It's not related to autopackage at all! If I run

~/.local/bin/package install VDrift\ 2007-03-20-minimal.package

then everything works fine. I guess I didn't install autopackage system-wide, and so the other (non-autopackage) executable called "package" was running. Everything works fine now.
03-20-2007, 01:09 PM,
Well that explains it! Now I feel silly having posted on the mailing list. Actually the response I got was quite helpful in explaining some things, so it wasn't a total wash, and I'll let them know that some rap-scallion has installed a non-autopackage "package" program on your Gentoo box, Joe, and that they should watch out for that. Wink
03-21-2007, 07:04 PM,
New test package with track map issue fixed:

I checked in all my changes to the build setup and things are looking ready for release in SVN r1627. Once I get some feedback on the package I may go ahead and tag the release, upload the packages, and post the release story.
03-21-2007, 07:52 PM,
install works fine, but when i try to run ./vdrift:

./vdrift: /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/ version `GCC_4.0.0' not found (required by ./vdrift)
./vdrift: /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/ version `CXXABI_1.3.1' not found (required by ./vdrift)
03-21-2007, 08:22 PM,
Looks like I need to statically compile the C/C++ libs in too so that version conflicts don't mess things up, that looks to be your problem - you have a different libstdc++ and libgcc than me (I'm using 4.0 and you're using 3.4).

Forum Jump:

Users browsing this thread: 1 Guest(s)