Forums
shadows on car look strange. - Printable Version

+- Forums (https://www.vdrift.net/Forum)
+-- Forum: Community (https://www.vdrift.net/Forum/forumdisplay.php?fid=3)
+--- Forum: Bugs (https://www.vdrift.net/Forum/forumdisplay.php?fid=7)
+--- Thread: shadows on car look strange. (/showthread.php?tid=896)



shadows on car look strange. - zimluura - 02-09-2008

so yeah, i got a windows exe together it looks allot better.

but shadows on cars look really strange sometimes.
[Image: shadow-tc6.jpg]
[Image: shaodw-mini.jpg]

is this expected behavior, or is something wrong??
winxp, 2gb, geforce7900gt (169.21 drivers)

if something *is* wrong, what would be a good place to start source diving?


- joevenzon - 02-09-2008

That's expected, unfortunately.... If you know how to fix these self-shadowing artifacts at a reasonable framerate, let me know. I do have one idea, but I'm not sure it'd work for all cars because it would require them to all be closed geometry.


- thelusiv - 02-10-2008

I hope this gets fixed, I really love the new shadows, but this makes them kinda suck. What causes it?


- joevenzon - 02-10-2008

Quote:What causes it?

Finite shadow map size and finite z-buffer resolution. There are ways to deal with it, but some of them require performance hits...

HOWEVER! I found a bug in the way the diffuse lighting was calculated that caused it to not line up with the shadow lighting, so things should look much better now in source R1941 and shaders R153.


- alex25 - 02-11-2008

speaking of shadows, they might look better in 24bpp (according to the comment in game.cpp added on release 1940) but on my 16bpp display vdrifit doesn't work any more, instead i get:

EXCEPTION: Error initilizing VDrift: Surface creation failed.

changing SDL_GL_DEPTH_SIZE back to 16bpp gets vdrift working again on my laptop. i really think we should query the display capabilities before we set things like this. i like nice shadows but i can live without them on my laptop if it means instead being able to run the program.

--alex--


- joevenzon - 02-12-2008

I set the depth buffer back to 16 bit in R1943. It doesn't actually help the shadow artifacts that much to have it at 24 bit anyway.


- thelusiv - 02-13-2008

Also, Joe has modified the shadows so that it's possible to see soft shadows. He left it commented out in the last SVN upgrade and it makes the shadow jaggies a little better. It doesn't quite fix it, but it masks the problem somewhat.

Joe why did you leave it commented out - performance issues? Still working on it? Should we include that in the next release?


- joevenzon - 02-15-2008

It's commented out for performance reasons. It'd be nice to have "soft shadows" as an adjustable menu setting (off/low/high).


- thelusiv - 02-21-2008

I see, I wondered if it was unfinished or something. Here's the issue entry for a soft shadows option: http://code.google.com/p/vdrift/issues/detail?id=56