Forums
Brake at race start - Printable Version

+- Forums (https://www.vdrift.net/Forum)
+-- Forum: Community (https://www.vdrift.net/Forum/forumdisplay.php?fid=3)
+--- Forum: Bugs (https://www.vdrift.net/Forum/forumdisplay.php?fid=7)
+--- Thread: Brake at race start (/showthread.php?tid=459)



Brake at race start - rookie1 - 11-30-2006

The current svn version starts the race at STAGING state. I've noticed it sets the player's car to full brake. And does not release the brake even after the race begins. I have to press the brake button once to get the brake released. This obviously makes a slower start. Can we change this behaviour to automatically release the brake once race begins?


- thelusiv - 11-30-2006

I didn't realize it was holding the brakes after the start. I'll look into this.


- joevenzon - 12-01-2006

It's because the way the code works is to apply the brakes when the state is STAGING. Once the state isn't STAGING, no value is asserted, and whatever normal controls are assigned are allowed to get through. When using a joystick, the axis set to brake will, at this point, be setting brake values of zero, and the brake is released. When using keyboard controls, zero values are only set once (to allow you to assign keyboard controls to things but then also override them with the joystick), and then the last value is held. At least, that's how it used to work, I'm not sure if the button ramping changed things. In this case, the last value was the STAGING brake setting, so that stays there until you press and release a key. To try to fix this, I've set up a default, zero brake value that always gets set unless anything else sets a value. Check it out, rev 1403, and let me know if it fixes the problem for you.


- rookie1 - 12-01-2006

Thanks Joe. Just did a quick test, seems the problem is still there.


- joevenzon - 12-02-2006

Whoops, I put the fix in the wrong block of code! It should *really* be fixed, now, in rev 1406.


- rookie1 - 12-02-2006

Thanks again Joe. It's fixed now. Smile