Forums
libopenal.so.1 - Printable Version

+- Forums (https://www.vdrift.net/Forum)
+-- Forum: Community (https://www.vdrift.net/Forum/forumdisplay.php?fid=3)
+--- Forum: Help (https://www.vdrift.net/Forum/forumdisplay.php?fid=5)
+--- Thread: libopenal.so.1 (/showthread.php?tid=434)



libopenal.so.1 - pwp71 - 11-20-2006

Hi everybody
where I can download libopenal.so.1

I have downloaded rpm about
OpenAL v. 0.0.8-1
ALUT v.1.1.0
to http://openal.org/downloads.html

OpenAL provide only libopenal.so.0
and when I try to compile VDrift under SUSE Linux 9.3 happen:

/usr/lib/gcc-lib/i586-suse-linux/3.3.5/../../../../i586-suse-linux/bin/ld: warning: libopenal.so.1, needed by /usr/lib/libalut.so, not found (try using -rpath or -rpath-link)
scons: done building targets.

Someone could give me some advice.

Thanks. pwp71


- Nigo - 11-21-2006

I'm sure that if you make a symbolic link libopenal.so.1 to libopenal.so, it'll work :oops: :lol:

assuming libopenal.so is in /usr/lib/, just type
ln -s /usr/lib/libopenal.so /usr/lib/libopenal.so.1


- pwp71 - 11-21-2006

OK. Thanks a lot, now work Big Grin .
I read previous post about link but I thought that the correct lib to link was libopenal.so.1 and libopenal.so.0 have trouble.

pwp71