Forums
Mac OS X release - Printable Version

+- Forums (https://www.vdrift.net/Forum)
+-- Forum: Community (https://www.vdrift.net/Forum/forumdisplay.php?fid=3)
+--- Forum: General Discussion (https://www.vdrift.net/Forum/forumdisplay.php?fid=8)
+--- Thread: Mac OS X release (/showthread.php?tid=152)

Pages: 1 2


Mac OS X release - christophe14 - 11-13-2005

I am very pleased and impressed by the work you are doing guys.Really this is a good job !!I am not a developer but for fun I have tried to compile the Mac OS X release. Unfortunately, it seems the file SDL.h is missing in the package.Could you please send it to me ?Thanks.Christophe


Mac OS X release - Nenillo - 11-13-2005

That file is not bundled with VDrift, you need to install dev packages of SDL to compile VDrift.


Mac OS X release - abs1nth - 11-14-2005

Nenillo Wrote:That file is not bundled with VDrift, you need to install dev packages of SDL to compile VDrift.
you should need:http://www.libsdl.org/release/SDL-devel-1.2.9.pkg.tar.gzhttp://www.libsdl.org/projects/SDL_image/release/SDL_image-1.2.4.pkg.tar.gzhttp://www.libsdl.org/projects/SDL_net/release/SDL_net-1.2.5.pkg.tar.gz


Mac OS X release - christophe14 - 11-20-2005

The file SDL.h is not in any of these packages.In fact, it is in http://www.libsdl.org/release/SDL-1.2.9.dmg.But I have some errors while compiling the project using Xcode 2.2. It seems the file config_mac.h is also missing in the src archive. Where can I find it ?I have also the following error:/Users/christophe/Desktop/vdrift 2005-11-03 src/tools/osx/../../include/settings.h:32: error: 'VERSION' was not declared in this scope.I had also to change the location path#include to #include Have anyone try to successfully compile the project provided in the archive vdrift-2005-11-03-src.tar.bz2 just like it is, without making any changes ?Thanks for your support.Christophe


Mac OS X release - christophe14 - 11-20-2005

christophe14 Wrote:The file SDL.h is not in any of these packages.In fact, it is in http://www.libsdl.org/release/SDL-1.2.9.dmg.But I have some errors while compiling the project using Xcode 2.2. It seems the file config_mac.h is also missing in the src archive. Where can I find it ?I have also the following error:/Users/christophe/Desktop/vdrift 2005-11-03 src/tools/osx/../../include/settings.h:32: error: 'VERSION' was not declared in this scope.I had also to change the location path#include to #include Have anyone try to successfully compile the project provided in the archive vdrift-2005-11-03-src.tar.bz2 just like it is, without making any changes ?Thanks for your support.Christophe
I cannot post any sentence with superior or inferior symbol ????#include SDL/SDL_image.h to #include SDL_image/SDL_image.hChristophe


Mac OS X release - thelusiv - 11-21-2005

christophe14 Wrote:I cannot post any sentence with superior or inferior symbol ????#include SDL/SDL_image.h to #include SDL_image/SDL_image.hChristophe
You can post things like that if you put them inside [ code ] tags (without the spaces).


Mac OS X release - abs1nth - 11-21-2005

christophe14 Wrote:It seems the file config_mac.h is also missing in the src archive. Where can I find it ?
please use the current version from svn since at the time the source release (the tar.gz you downloaded) happened, mac support was broken :wink: (well config_mac.h was moved and the xcode project didn't know about it)the following errors are just symptoms of config_mac.h not beeing found


Mac OS X release - christophe14 - 11-21-2005

OK.Could you tell me the easiest SVN client to use on Mac OS X to retrieve the source code ?Thanks.


Mac OS X release - thelusiv - 11-22-2005

It looks like the Mac OS X section on this page has a client you can use. I don't know if it's the easiest, but I don't have an Apple, so...


Mac OS X release - abs1nth - 11-23-2005

thelusiv Wrote:It looks like the Mac OS X section on this page has a client you can use. I don't know if it's the easiest, but I don't have an Apple, so...
this is the standard command line client, if you managed to get it installed you can use it to check out vdrift by opening /Applications/Utilities/Terminal.app and typing inConfusedvn co http://svn.vdrift.net/repos/vdrift/trunk vdriftor you could just wait for the next release in a few days ^^ (i'm assuming here that there will be a december release altough not much happened in svn...)


Mac OS X release - christophe14 - 11-23-2005

Finally I have installed the Martin Ott Subversion package (http://homepage.mac.com/martinott/) and svnX (http://www.lachoseinteractive.net/files/svnX.dmg.gz) and I have successfully checkout the latest version of the source code (Rev 580).But it still doesn't compile with Xcode 2.2 :cry: Error when choosing Deployment-Release active build configuration: "pbxcp: error: open(): /Volumes/Documents/vdrift/tools/osx/build/Deployment-Release/vdrift.app/Contents/Info.plist [/SourceCache/pbx_tools/pbx_tools-628.1/pbxcp/file_utils.c:391]: No such file or directory"Or Error when choosing both Development or Deployment active build configuration "error: couldn't exec /usr/bin/gcc-3.3: No such file or directory".Which version of Xcode are you using ?Or maybe I should checkout the version revision 535 ?


Mac OS X release - abs1nth - 11-24-2005

christophe14 Wrote:Which version of Xcode are you using ?
i'm using 2.2 the newest version
christophe14 Wrote:"error: couldn't exec /usr/bin/gcc-3.3: No such file or directory".
are you sure you have the developer tools properly installed?try re-installing xcode 2.2 and be sure to check that all the cross-compiling options and all gcc versions are installed (the install can be customized)


Mac OS X release - abs1nth - 11-24-2005

christophe14 Wrote:Or maybe I should checkout the version revision 535 ?
no i just checked, the newest version (trunk) works fine (here ;-)


Mac OS X release - christophe14 - 11-27-2005

I have spent the all week to re-install from scratch Mac OS X 10.4.2. In fact, after having installed svn - I can't be sure this is linked - but Mac OS X was not able anymore to launch any BSD commands.I will keep you informed if now I can compile the project...


Mac OS X release - christophe14 - 11-29-2005

Well, now I can compile the files BUT it doesn't link.... :cry: I have the following errors"/usr/bin/ld: table of contents for archive: /Volumes/Documents/vdrift_580/tools/osx/libfmod.a is out of date; rerun ranlib(1) (can't load from it)"How can I rerun ranlib and what is it ???and "/usr/bin/ld: warning prebinding disabled because dependent library: /Developer/SDKs/MacOSX10.3.9.sdk/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit can't be searched"Why the Mac OS X 10.3.9 SDK is used and not the Mac OS X 10.4 SDK ? (Maybe this is a stupid question)Definitively, even if I don't know many things about Mac OS X development, I feel frustrated not being able to compile the project just by clicking on the build icon. I strongly believe a FAQ or readme file is necessary explaining how to compile successfully the project on Mac OS X.What's your feeling ?