Forums
my first imported car, not good - Printable Version

+- Forums (https://www.vdrift.net/Forum)
+-- Forum: Community (https://www.vdrift.net/Forum/forumdisplay.php?fid=3)
+--- Forum: Help (https://www.vdrift.net/Forum/forumdisplay.php?fid=5)
+--- Thread: my first imported car, not good (/showthread.php?tid=1234)



my first imported car, not good - portets - 02-04-2010

so decided to try to import my first car.
i have no experience in blender whatsoever.

i installed blender, figured out how to add import/export scripts, found a gpl car model(you'll see what it is eventually), found out how to change faces to triangles, exported as body.joe into the SV car's folder.

but anyway, here's what happened:

[Image: 1_vimport.jpg]

what's going on? i was able to export a giant cube without problems.(other than drivability ) :wink:
is it because my model is too high poly? (it's high, i just don't know how high)

edit: also, while the cube worked perfect, this model causes a segmentation fault if it was your last car choice on the car selection screen.
as in, it segfaults unless the selection screen starts out on a different car and then you scroll to this car.


- NaN - 02-04-2010

Have you tried the old export script export-joe-0.3.py or the new export-joe.py.
Could you upload the blend file.


- portets - 02-04-2010

export-joe.py results in:

Code:
INFO: Loaded fonts successfully
INFO: Loaded GUI successfully
vdrift: include/model.h:106: AABB<float> MODEL::GetAABB() const: Assertion `generatedmetrics' failed.
SIGABRT detected, releasing the mouse
Aborted

so i used the older export-joe-0.3.py

i can't get the .blend uploaded right now due to uploading issues, but when uploading starts working again i will. any advice in the meantime?


- NaN - 02-04-2010

I imported XS into blender using import-joe, and exported it with export-joe. It loads fine in vdrift. Maybe car parameters file is broken? Check if you have set the right file format version. http://wiki.vdrift.net/Car_parameters


- portets - 02-04-2010

the car parameters should be fine.

and i was able to export the M1 in the art repository with export-joe.py just fine. same with other cars.

i guess it's just this particular blend that has trouble with export-joe. either of them.

what are you supposed to do to .blend's to prepare them for vdrift export? i un-checked the double-sided option, and i converted all faces to triangles. anything i'm missing?


- NaN - 02-04-2010

Lets say you are using M1 car file for your new car. Import M1 and compare it to your car mesh. Make sure your mesh has the same size/orientation. There is no need to convert quads to tris the script is going to do it for you anyways.

There is also a collision.joe. The importer fails on it, i will fix it asap. So you may try to use collision.joe from M1.


- portets - 02-04-2010

hmm..
after adjusting the size and orientation i get the same result.
the .joe that export-joe.py exports causes the game to crash. and export-joe-0.3.py gives the same ugly black smear.

is there a polygon limit? the model i'm trying to export has 50,000 vertices and 45,000 faces. (if i'm reading that right)


- NaN - 02-04-2010

I see. JOE has a hard coded limit of 32768 normals/vertices/uvs, as it is using a short for the indices.


- joevenzon - 02-04-2010

The collision.joe file is no longer used. Now the collision information gets automatically generated from the body mesh and wheels.

One way around the triangle limit (besides changing the format) would be to break up the mesh into multiple parts and then implementing zimluura's multiple mesh per car idea:
http://code.google.com/p/vdrift/issues/detail?id=3


- portets - 02-04-2010

okay, i lowered the poly with a decimate modifier and it works!
say hello to the EF(will that work as it's name?)

[Image: 6_enzo.jpg]

now i just need to shrink the model about 33% and rotate it 180 degrees. i also need to figure out how to join the body panels back together because the decimate unjoined a few things.

oh, why are some of the body panels black? the doors, front left fender, etc... they look like that in blender also


- portets - 02-05-2010

joevenzon Wrote:One way around the triangle limit (besides changing the format) would be to break up the mesh into multiple parts and then implementing zimluura's multiple mesh per car idea:
http://code.google.com/p/vdrift/issues/detail?id=3

ooh, that could be nice. so vdrift doesn't have this capability yet?
and can vdrift only read cars in .joe format?

also, for some reason the highest face count that vdrift will load without crashing on me has been 1174. that's a bit low....
this model looks terrible that low! :lol:


- joevenzon - 02-05-2010

That doesn't seem right. Once you post your .blend we can take a look at it.


- portets - 02-05-2010

okay, here's the .blend of the enzo. this isn't the original, it's the one that i removed the badging, changed size and position, pretty much should be redy for export, but it's not decimated. still full poly.

https://docs.google.com/uc?id=0ByBA2iQHjx06MTliZDU1NWQtZmZmNy00OTk3LTkyYWItMTljM2FmNGVmY2E2&export=download&hl=en

if you want, i can post the original, but it's a bigger file.

edit: i got the .car file set up real nice! i really like how it drives. and i used audacity to modify the engine sound of the SV for this car. got it sounding like a dirty v12, which is what the enzo sounds like from what i've heard of it. :wink: