Forums

Full Version: Error loading texture file
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, I just downloaded Vdrift today on my lenovo y410 laptop running ubuntu 8.04

This is what happens when I try to run the game:

Code:
agastya@agastya-laptop:~/Downloads/vdrift-08-05-08$ ./vdrift
BinReloc successfully initialized.
Executable path: /home/agastya/Downloads/vdrift-08-05-08/vdrift
Data dir: /home/agastya/Downloads/data
Localedir: /home/agastya/Downloads/share/locale
No data_dir found in VDrift.config, using /home/agastya/Downloads/data
/home/agastya/Downloads/data/settings/VDrift.config not found. Attempting to load data from /home/agastya/Downloads/vdrift-08-05-08/data
Found config file /home/agastya/.vdrift/controls.config.
Found config file /home/agastya/.vdrift/VDrift.config.
No data_dir found in VDrift.config, using /home/agastya/Downloads/vdrift-08-05-08/data
Version of game: development-full
Skin name not found in config file...
/home/agastya/Downloads/share/locale
Directory /home/agastya/Downloads/vdrift-08-05-08/data/skins/SConscript/menus does not exist! Skin SConscript not loaded.
Run with -verbose for troubleshooting.
Run with -nosound to disable sound.
Run with -benchmark to play a replay and output benchmark data.
0 joystick(s) found:
Card supports: drawbuf8 auxbuf4 antialiasing anisotropy16 cubemapping shaders multitexturing32(4) texture_rectangle depth_texture shadow framebuffer_objects
Card does not support:
Status: Using GLEW 1.5.0
Fragment shaders enabled
Loaded shader package simple
Loaded shader package full
Loaded shader package full-noshadow
Loaded shader package blurpass
Loaded shader package depthgen
Framebuffer object complete
Framebuffer object complete
EXCEPTION: src/textures.cpp, line 489:  Error loading texture file: skins/simple/textures/loading0.png (/home/agastya/Downloads/vdrift-08-05-08/data/skins/simple/textures/loading0.png)

agastya@agastya-laptop:~/Downloads/vdrift-08-05-08$

I checked the directory skins/simple/textures and it does contain loading0.png
How do I fix it so I can start playing??

Thanks in advance
What kind of video card do you have? Do other 3D applications run OK?
I have an nvidia 8400M GS gfx card...
the only other game I've tried is torcs and that runs fine on my system
Someone seems to have posted the same error as a bug

http://vdrift.net/Forum/viewtopic.php?t=950

clytle374 Wrote:I might be missing something here but after installing with scons I always have to reinstall the data directory. Most of it is installed but somethings are missing. Resulting in errors like.

Code:
EXCEPTION: src/textures.cpp, line 489:  Error loading texture file: skins/simple/textures/loading0.png (/usr/share/games/vdrift/data/skins/simple/textures/loading0.png)

This is been happening for a long time, and though I should let someone know. Or someone let me know what I'm missing.

I have been looking into a SVN build option for portage(gentoo) to automate the SVN install.
I think in that case the problem was that those data files didn't exist because the scons install script didn't actually copy them over.

This is what it looks like when I start up:

Code:
BinReloc successfully initialized.
Executable path: /home/joe/code/VDrift-releases/vdrift-08-05-08/build/vdrift
Data dir: /home/joe/code/VDrift-releases/vdrift-08-05-08/data
No data_dir found in VDrift.config, using /home/joe/code/VDrift-releases/vdrift-08-05-08/data
Found config file /home/joe/.vdrift/controls.config.
Found config file /home/joe/.vdrift/VDrift.config.
No data_dir found in VDrift.config, using /home/joe/code/VDrift-releases/vdrift-08-05-08/data
Version of game: development-full
Skin name not found in config file...
Directory /home/joe/code/VDrift-releases/vdrift-08-05-08/data/skins/SConscript/menus does not exist! Skin SConscript not loaded.
Run with -verbose for troubleshooting.
Run with -nosound to disable sound.
Run with -benchmark to play a replay and output benchmark data.
1 joystick(s) found:
    0. Gravis Eliminator AfterShock
Card supports: drawbuf4 auxbuf4 antialiasing anisotropy16 cubemapping shaders multitexturing16(4) texture_rectangle depth_texture shadow framebuffer_objects
Card does not support:
Status: Using GLEW 1.5.0
Fragment shaders enabled
Loaded shader package simple
Loaded shader package full
Loaded shader package full-noshadow
Loaded shader package blurpass
Loaded shader package depthgen
Framebuffer object complete
Framebuffer object complete

My compilation process was simply:
* untar the archive
* cd to the archive
* cd to the bullet-2.66 folder
* ./configure
* jam bulletcollision bulletmath
* cd ..
* scons -j 3
* ran build/vdrift

Is that what you did?