Forums

Full Version: ABS/TCS can't be toggled during race countdown
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
This is very annoying when you're trying to get a good launch but you can't turn off TCS during the countdown...
Fixed R1926.
OK, that's fixed, thanks. I've remembered some other ABS/TCS related bugs and this thread is as good as any for bringing them up. The first two are probably easy to fix:
  • TCS sometimes engages while the car is in Neutral. This is annoying when trying to launch the car but wanting to leave TCS toggled on. This is easy to reproduce with the F1-02 rolling slowly on the grass on most any track.
  • TCS does not engage at all in reverse gear. This is a little unexpected, one gets used to having TCS when using it, and then in reverse one expects it to continue working, but it doesn't.
  • TCS makes it impossible to get out of the grass with some cars. This is probably well solved by being able to turn it off, but maybe it's too sensitive. In the F1-02, it is so hard to get out of the grass that the car often stalls in 1st gear.
  • ABS and TCS are not remembered in replays. If a replay is recorded with ABS and TCS on, then they are turned off half way through, and then back on again near the end, this will not show up in the replay. Instead the player can turn ABS/TCS on and off as much as desired while the replay plays, making the replay lose sync.
The first two bullets should be fixed in R1932.
Cool, these both seem fixed pretty well. Thanks. The 4th one needs some changes in the replay system probably...any thoughts on #3?
#4 wouldn't be toooo hard... maybe when I get in there to redo the replay system w/ the serialization library I'll do #4 too.

For #3, can you provide me an example car/track combo where this is really obvious?
joevenzon Wrote:For #3, can you provide me an example car/track combo where this is really obvious?
OK, to clarify the original problem a little, it is more a problem in the sand traps than on the grass. Try the F1-02, on Estoril '88, turn on TCS, go off the track at the first turn and into the sand pit. Stall the car, then try to start it up again from 1st gear with TCS still on.
thelusiv Wrote:Stall the car, then try to start it up again from 1st gear with TCS still on.

I didn't have any trouble getting out of the sand trap. I was able to get out as fast with TCS on as with it off. Are you using the latest SVN? There were some autoclutch changes recently that might be the reason we're seeing different things.
I don't use the autoclutch, and I still see the problem with the latest revision.