Forums

Full Version: R1824 and 1825 not running
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Just doesnt open. on Power iMac G5 mac os x 10.4.11 when ran from terminal i get this error
Code:
Last login: Mon Aug 27 23:21:18 on ttyp1
/Users/David/vdrift/trunk/vdrift.app/Contents/MacOS/vdrift; exit
Welcome to Darwin!
david-xerris-imac-g5:~ David$ /Users/David/vdrift/trunk/vdrift.app/Contents/MacOS/vdrift; exit
dyld: Library not loaded: /Library/Frameworks/Ogg.framework/Versions/A/Ogg
  Referenced from: /Users/David/vdrift/trunk/vdrift.app/Contents/MacOS/vdrift
  Reason: image not found
Trace/BPT trap
logout
[Process completed]
Seems some image is missing. any help? just did a complete data update (deleted old data folder) and updated to Rev 1824. any ideas? :?:
Any ideas or not. kinda bored tonight and feel like testing.
It looks like it's missing the Ogg library. I don't know much about the current state of the OS X build but you could check out the posts in the "libvorbis" thread.
OK will check that out.
Yea. Hmm. Let me know if you sorted anything out on that, my builds should be working (you can pull them from my website) on both powermac and intel machines.
Couldn't fix it. what is the difference between your builds and the one on vdrift? if you fixed the build why don't you just put your fix on the svn?
My build is in SVN - and it seem to work for most people so far. My thoughts were simply try the package I made with the dataset include and see what happens. If it works, compare file lists, etc. - its just one more way to troubleshoot what's going on.
still cant get it to run. check out your website found nothing there except for stuff about your dakota. (nice truck btw)
Er. Try cotharyus.net Smile
:o :o :o GASP!!!!
cotharyus Wrote:My build is in SVN - and it seem to work for most people so far. My thoughts were simply try the package I made with the dataset include and see what happens. If it works, compare file lists, etc. - its just one more way to troubleshoot what's going on.

I think the problem is that the machine in question here is a G5 ( power pc ) all machines up unitl then have been intel-based.... and the lib files checked in to svn are x86-only ( not universal ).

To fix this, add
Code:
-arch i386 -arch ppc
to the gcc commands that build and link the dylibs. If you are using xcode, there is a project property somewhere that lets you specify the target platforms ( specify both )...

... oh and you will need the univeral sdk installed and referenced ( get it from developer.apple.com... reference it with
Code:
-isysroot /Developer/SDKs/MacOSX10.4u.sdk -Wl,-syslibroot,/Developer/SDKs/MacOSX10.4u.sdk

The scons script does this stuff, so you can look in to it for reference.
cant find what your saying. can you fix it and put it in revision 1826? not sure what 1825 fixed but it still has this problem. Sad
I thought we were now using SCons to build the OS X version as well? Has this changed?
i always used xcode. never heard of using scons to do it!
kidrock - Relesases works, and the xcode project is done for both i386 and ppc architecture.

cotharyus - When i compiled the ogg frameworks i did a change in xcode project architecture: initialy the architecture flag was clearly depending of the architecture of the host (dynamic flag). I erased this and put it to i386 ppc. It compiled well a universal binary. Did you do this ?
Pages: 1 2 3