Forums

Full Version: seg fault with svn r1750
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
just did a svn update, looks like lots of things changed, unfortunately i get a seg fault in ode:

Code:
#0  0xb7d0d3c1 in gim_trimesh_update_vertices () from /usr/lib/libode.so.0
#1  0xb7d0d49e in gim_trimesh_update () from /usr/lib/libode.so.0
#2  0xb7cfdaab in dxTriMesh::computeAABB () from /usr/lib/libode.so.0
#3  0xb7cd386a in dxQuadTreeSpace::cleanGeoms () from /usr/lib/libode.so.0
#4  0xb7cd41e3 in dxQuadTreeSpace::collide2 () from /usr/lib/libode.so.0
#5  0xb7cd51b3 in dSpaceCollide2 () from /usr/lib/libode.so.0
#6  0xb7ccdf14 in ?? () from /usr/lib/libode.so.0
#7  0xb7ccee6d in dCollide () from /usr/lib/libode.so.0
#8  0x080fe863 in PHYSICS::CollideBox (this=0x86f5700, position=@0xbf84d924,
    orientation=@0xbf84d7a4, dimensions=@0xbf84d988,
    outputcontactlist=@0xbf84d93c, settings=@0xbf84d944) at src/physics.cpp:180
#9  0x0813f510 in Vamos_World::World::interact (this=0x8ed95d8, car=0x9164410,
    segment_index=0) at src/vamos/world/World.cc:272
#10 0x080cdacf in VAMOSWORLD::PhysUpdate (this=0x86f526c, dt=0.00400000019)
    at src/vamosworld.cc:2388
#11 0x080d4bc0 in VAMOSWORLD::Update (this=0x86f526c, timefactor=1, fps=250,
    js=0x81bfa40) at src/vamosworld.cc:724
#12 0x08061e00 in GAME::Update (this=0x81bdc00) at src/game.cpp:219
#13 0x08064ec1 in GAME::Start (this=0x81bdc00, args=@0xbf84ea44)
    at src/game.cpp:1564
#14 0x0804f1da in main (argc=1, argv=0xbf84eb04) at src/main.cpp:31

can't wait to get this working as i want to test all those tracks i have converted but not released yet because of various problems with the old pre-ode code.

--alex--
alex25 Wrote:just did a svn update, looks like lots of things changed, unfortunately i get a seg fault in ode:

never mind. i switched to the svn version of ode (as opposed to using the debian package) and now i can start the program. unfortunately the texture size setting doesn't seem to work any more, so it's always loading the high textures which makes it unbearable slow on my laptop and then when i touch the wall the car takes off and goes airborne (like a plane) so something is not quite working with the collision code.

--alex--
Looks like this is the gimpact crash. For some reason using gimpact (the default collision lib in recent ODE versions) causes a crash. See this post for the work-around:

http://vdrift.net/Forum/viewtopic.php?p=5375#5375
Whoa, the svn version of ode makes this work for you? Awesome. I'll have to check it out.

Yes, the collision is pretty broken. The collision detection is excellent, but the response code is still wrong somehow.

Regarding the speed, can you check out this forum post:
http://vdrift.net/Forum/viewtopic.php?p=5396#5396
joevenzon Wrote:Whoa, the svn version of ode makes this work for you? Awesome. I'll have to check it out.

Yes, the collision is pretty broken. The collision detection is excellent, but the response code is still wrong somehow.

At the risk of going off on a tangent, what video card do you have? How slow is slow? Also, what do you get for these lines (shown on the console when vdrift starts up):

Card supports: drawbuf4 auxbuf4 multitexturing4 antialiasing anisotropy16 cubemapping shaders texture_rectangle depth_texture shadow
Card does not support:

this is on my thinkpad with a radeon card which is pretty basic but with low textures i was able to run vdrift before and get resonable fps (something like 20-30 depending on the track, etc). now i get around 2-3 which makes it pretty much unplayable.

this is the output i get when vdrift starts:

Code:
Extension not supported: GL_ARB_fragment_program
Extension not supported: GL_ARB_depth_texture
Extension not supported: GL_ARB_shadow
Card supports: drawbuf-1076669260 auxbuf0 multitexturing6 antialiasing anisotropy16 cubemapping texture_rectangle
Card does not support: shaders depth_texture shadow

--alex--