Forums

Full Version: glibc
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Hi there!

I'm using Ubuntu 6.10 on a AMD-64 1.8Ghz with 1GB RAM and an on-board nvidia geforce 6150.
I tried installing vdrift from the latest package file (vdrift-2006-10-06-full.x86.package). However, when I try to unpackage it,

(rishabh@rishabh-desktop:$ ./vdrift-2006-10-06-full.x86.package)

it says:

(autosu-gtk:18505): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.


# Preparing package: VDrift
# Checking for required C library versions ... failed
# FAIL:
# Your copy of glibc, a core system library, is too old for this package.
# You need at least the following symbols in glibc: GLIBC_2.0.
#
# This error normally means that whoever built the package did not build it correctly.
# Please report the contents of this message to the provider of this package, and
# ask them to rebuild it using apbuild.
#
# Upgrading glibc is highly dangerous, so we recommend in this situation that you
# compile the app you want to install from the sources if possible. Sorry Sad
FAIL: Unable to prepare package VDrift.


I also tried the *.deb files (data and installer, amd64), but it's a no-go.

Thanks in advance.
I'll have a 64-bit package for the latest version out very soon. Wait a day or so. I might have it done tonight.
So there's no way for me to get this working?
Well, I suppose a wait can't hurt me :lol:
Can you give me a link to the latest version?
Thanks
Try this one, just built it on my Ubuntu 6.10 AMD64 machine: http://clemsonlinux.org/~thelusiv/VDrift...64.package

By the way, are you using Ubuntu 6.10 for x86, or Ubuntu 6.10 for AMD64? That package was made on an actual AMD64 install...
Actually, that package won't work, I didn't test it before uploading (silly me) and it fails when checking for libraries, even on the machine that built it. I have commented out the library checks and built a new package, it's available now at the same location: http://clemsonlinux.org/~thelusiv/VDrift...64.package
Hi,
I'm using the AMD64 build of ubuntu.
I'm downloading the package now, I'll tell you when I'm through.
Well, the package installed successfully, but when I click "Practice", "Single race" or "network race" it exits the game. The only thing that works is the "options" menu...
In fact the terminal says:

rishabh@rishabh-desktop:~$ vdrift
BinReloc successfully initialized.
Executable path: /usr/share/games/vdrift/bin/vdrift
Data dir: /usr/share/games/vdrift/data
Localedir: /usr/share/games/vdrift/share/locale
No data_dir found in VDrift.config, using /usr/share/games/vdrift/data
Found config file /home/rishabh/.vdrift/controls.
Found config file /home/rishabh/.vdrift/VDrift.config.
No data_dir found in VDrift.config, using /usr/share/games/vdrift/data
Version of game: 2007-03-23
Skin name not found in config file...
Warning: option-50 is missing its default value. Assuming "".
Force feedback device: /dev/input/event0
Force feedback gain: 2
Force feedback inverted: 0
Run with -verbose for troubleshooting.
Run with -nosound to disable sound.
Run with -benchmark to play a replay and output benchmark data.
1 joystick(s) found:
0. Microsoft SideWinder Joystick
Multitexture: Yes
Texture units: 4
Antialiasing: Yes
Anisotropic texture filtering: Yes
Maximum Anisotropy: 16
Multitexture units (4 are required for all effects): 4
Your GPU meets the texture unit requirements.

Note to user: All error messages will be put in /home/rishabh/.vdrift/logs/.
error loading texture file "/usr/share/games/vdrift/data/cars/TL/textures/shadow.png"...
Segmentation fault (core dumped)
rishabh@rishabh-desktop:~$


So that means the Data files are improperly installed?
How do I install them then? I have the tarball (vdrift-2006-10-06-data-full.tar.bz2). Will that help?
Can you run it on a terminal and post the output you get, especially when it exits?

I had to remove all the library checks to get it to work on AMD64, so you may be missing a library. Those menus all have 3D stuff in them so it's likely you're missing some kind of OpenGL or GLU stuff...
Ah OK, I think I know what happened...

Don't install the old data. This package is the minimal data set, and you probably have leftover configuration files from the previous install. You need to delete your ~/.vdrift directory and try to run it again.

edit: that might not work. I just realized the default VDrift.config has the selected_car set to a car that is not distributed with the minimal set. Change your ~/.vdrift/VDrift.config so that selected_car = TL2. That should fix it.
I over-wrote the /usr/share/games/vdrift/data folder with the data folder in the tarball, and now the game doesn't even start.

And to crown it all, the log files are completely empty!
Sorry, I didn't notice your reply.
I'll try that now.
When I click "single race" (or any type of race, for that matter) the terminal says:

error loading texture file "/usr/share/games/vdrift/data/cars/TL/textures/shadow.png"...
Segmentation fault (core dumped)

Maybe the textures are being improperly installed?
I'm so sorry! stupid of me!
I changed the TRACK to TL2. :oops:

Now it works fine!
Thanks a lot!
Anyway, is it possible to use the full data set to work with the AMD64 package?
Pages: 1 2 3