Forums

Full Version: Mutual dependency - can't install
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Code:
/usr/share/games/vdrift$ bash: ./vdrift: No such file or directory

I'm starting to think Nigo had a good point there earlier.
Yep Nigo was right, sorry for leading you astray but the link I gave you was only the data package. I had forgotten that Matthew only created an AMD64 .deb around release time, and so there is no i386 .deb to go with the data package I told you to install.

Now I tried on Ubuntu Dapper (what I'm running until I have time to upgrade) and the following did not work, because Dapper does not have the same version of SDL as these packages require (they are for Debian unstable I think). Here are the Debian packages for the 2006-10-06 release made by Goneri Le Bouder, a member of the Debian Games team. You'll need at least the i386 binary package, plus the minimal data package at least. If you want to install the full data, then you'll also need the full data package (note: the minimal data package is not optional). You can find these packages here:
http://ftp.us.debian.org/debian/pool/main/v/vdrift/

or on any other Debian mirror in a similar location. The files you will need are:
vdrift_0.0.2006.10.06-1_i386.deb
vdrift-minimal_0.0.2006.10.06-1_all.deb
vdrift-full_0.0.2006.10.06-1_all.deb [optional]

To install them use the same command as before but provide all of the files you wish to install.
Code:
sudo dpkg -i vdrift_0.0.2006.10.06-1_i386.deb vdrift-minimal_0.0.2006.10.06-1_all.deb
That would install just the minimal data, add the full package to that for all of it.
Code:
dpkg: dependency problems prevent configuration of vdrift:
vdrift depends on libc6 (>= 2.3.6-6); however:
  Version of libc6 on system is 2.3.6-0ubuntu20.
vdrift depends on libgcc1 (>= 1:4.1.1-12); however:
  Version of libgcc1 on system is 1:4.0.3-1ubuntu5.
vdrift depends on libsdl-image1.2 (>= 1.2.5); however:
  Version of libsdl-image1.2 on system is 1.2.4-1.
vdrift depends on libsdl1.2debian (>= 1.2.10-1); however:
  Version of libsdl1.2debian on system is 1.2.9-0.0ubuntu2.
vdrift depends on libstdc++6 (>= 4.1.1-12); however:
  Version of libstdc++6 on system is 4.0.3-1ubuntu5.
dpkg: error processing vdrift (--install):
dependency problems - leaving unconfigured
Setting up vdrift-minimal (0.0.2006.10.06-1) ...
Errors were encountered while processing:
vdrift
huhuhuhu :lol:

you can try to update all this libs using apt-get or synaptic... good luck :roll:
You still have two other options: trying the generic autopackage install, or building from source. Neither is too hard, but the autopackage is probably a bit easier:

Go here:
http://sourceforge.net/project/showfiles..._id=453252

and download "vdrift-2006-10-06-full.x86.package"

after you download it you'll have to do "chmod 755 vdrift-2006-10-06-full.x86.package" to make it executable and then run it with "./vdrift-2006-10-06-full.x86.package"
So none of the .debs work for the current versions of Ubuntu because of the versions of SDL used in Ubuntu. I'd suggest using the autopackage, this will probably work the best.

Anybody want to claim the title of Ubuntu package maintainer?
Well, I managed to get it installed OK. I don't think it was ever meant to run on a laptop, though. Is there anything I can do to boost performance?
Lowering detail settings, resolution and view distance will help. You can also disable the speedo and rpm meters and framerate meter, that will also help.
Pages: 1 2