Forums

Full Version: car sound bug?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
when in car the sounds are good but when i use the chase camera the engine sounds and the other sounds are too quiet.Is there a way to add sounds to the tracks ?
(09-25-2014, 07:43 AM)slickx Wrote: [ -> ]when in car the sounds are good but when i use the chase camera the engine sounds and the other sounds are too quiet.Is there a way to add sounds to the tracks ?

What are your sound volume setings?

Check the discussion in the release thread: http://vdrift.net/Forum/showthread.php?tid=1835

The sound attenuation has been changed to handle multiple car sounds better. With the old one it was way too loud, the new seems to be too quiet.

I'd like to make it tweakable.

Option 1:
Expose global attenuation settings which would apply to all 3d sounds. Something like:
min_distance = 0.5 # distance at which the sound is 100%
max_distance = 100 # distance at witch the sound is at -60dB (0.1%)
falloff = none/linear/log/inverse # shape of the attenuation

Option 2:
Currently car sounds are hadled for each car. The simplest approach I see is to expose all car sound properties in the aud file, make it non-optional. This means each car would have to have a <car name>.aud file. Or let's call it <car name>.snd to avoid mixing it up with the old stuff. This would allow to tweak all sound settings per car.


EDIT:
Alternative more flexible attenuation description would be to use a spline instead of min/max/falloff:
attenuation.0 = 0.5, 1.00 # 0.5 meter gain = 1.00
attenuation.1 = 2, 0.50
attenuation.2 = 8, 0.20
attenuation.3 = 20, 0.10
attenuation.4 = 80, 0.01 # 80 meter gain = 0.01



Here is how attenuation looks like currently (blue = old, red = current): http://fooplot.com/plot/1abri4jnbo
Has the bug been fixed?