Forums

Full Version: OpenGL 3.3 renderer rewrite
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5
hmm. still the same.

oh, and when i said black screen i meant the main menu doesn't show up; no gui.
i get the same thing when i load up with -gl3



./vdrift3084 -gl3
INFO: Multi-processor system detected. Run with -multithreaded argument to enable multithreading (EXPERIMENTAL).
INFO: Starting VDrift: development-full, Version: 3084M, O/S: Unix-like
INFO: Home directory: /home/zimluura
INFO: Settings file: /home/zimluura/.vdrift/VDrift.config
INFO: Data directory: data
DATA_DIR: /usr/local/share/games/vdrift/data
INFO: Temporary directory: /home/zimluura/.vdrift/tmp
INFO: Log file: /home/zimluura/.vdrift/log.txt
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Enabling antialiasing: 2X
INFO: Display change was successful: 1280x720x32 24z fullscreen=0
INFO: GL Renderer: GeForce GTX 460/PCI/SSE2
INFO: GL Vendor: NVIDIA Corporation
INFO: GL Version: 4.1.0 NVIDIA 260.19.36
INFO: Initialized GLEW 1.5.6
INFO: Loading data/shaders/gl3/vdrift1.rhr...
INFO: Loaded data/shaders/gl3/vdrift1.rhr
INFO: GL3 initialization successful
INFO: 0 joysticks found.
INFO: Loading car controls from: /home/zimluura/.vdrift/controls.config
INFO: Sound initialization information:
INFO: Obtained audio device:
Frequency: 44100
Format: 32784
Bits per sample: 16
Channels: 2
Silence: 0
Samples: 1024
Size: 4096
Sound initialization successful
INFO: Loaded fonts successfully
INFO: Loaded GUI successfully



tried killing my VDrift.config and got the same black screen (lower resolution though)


specs: amd phenom2 4x @ 3.4Ghz, 8Gb ram, evga geforce gtx 460 w/ 1Gb, ubuntu 10.10 (no visual effects turned on atm)
I'm primarily developing on an ATI machine now; I bet this is because you guys have NVIDIA cards. I'll test on my windows machine, it's got a 460GTX....
OK I think I finally found the problem and got this working for NVIDIA drivers. Turns out the NVIDIA drivers are really strict about texture completeness and mipmapping (which is good!). Try R3091/813.
Works for me now. Thanks
YES!!!! Now it works! Smile
There are only a couple of problems. First at menu you can't see the car. Second in the game the sky is not visible and the car has no shader but only a flat color.

Without -gl3 option:
[Image: withoutgl3.jpg]

And with -gl3 option:
[Image: withgl3.jpg]

However the fps are doubled with -gl3 options.
gianni Wrote:YES!!!! Now it works!

Hooray! Finally. :-)

Quote:There are only a couple of problems. First at menu you can't see the car. Second in the game the sky is not visible and the car has no shader but only a flat color.

Yes, right now the GL3 renderer is using only very basic shaders and skips drawing some of the scene. However it should be easy to add the rest now that the base is working.
Hi
cool but coming from NeedForSpeed shift2 i was disappointed by graphics....
http://www.youtube.com/watch?v=RUkBZxaHkwg
but as it says shaders disabled I might be missing something? Also no fullscreen, only windowed with the latest CVS downloaded today.
Can I use my ch yoke? I'll try right now. Would be cool as for now with nfs i can only use the keyboard.
Thanks Michael


michael@ubuntu:~/CPP/vdrift1/build$ ./vdrift -gl3
INFO: Multi-processor system detected. Run with -multithreaded argument to enable multithreading (EXPERIMENTAL).
INFO: Starting VDrift: development-full, Version: 3131, O/S: Unix-like
INFO: Home directory: /home/michael
INFO: Settings file: /home/michael/.vdrift/VDrift.config
INFO: Data directory: /usr/local/share/games/vdrift/data
DATA_DIR: /usr/local/share/games/vdrift/data
INFO: Temporary directory: /home/michael/.vdrift/tmp
INFO: Log file: /home/michael/.vdrift/log.txt
INFO: SDL initialization successful
INFO: SDL video query was successful
INFO: Enabling antialiasing: 4X
INFO: Display change was successful: 1680x1050x32 16z fullscreen=0
INFO: Video card information:
Vendor: NVIDIA Corporation
Renderer: GeForce GTX 460/PCI/SSE2
Version: 4.1.0 NVIDIA 260.19.44
Maximum texture size: 16384
Maximum varying floats: 60
Using GLEW 1.6.0
INFO: Maximum color attachments: 8
INFO: Maximum draw buffers (1 required): 8
INFO: Disabling shaders
INFO: Maximum anisotropy: 16
INFO: 1 joystick found:
INFO: 0. CH PRODUCTS CH FLIGHT SIM YOKE USB
INFO: Loading car controls from: /home/michael/.vdrift/controls.config
INFO: Sound initialization information:
INFO: Obtained audio device:
Frequency: 44100
Format: 32784
Bits per sample: 16
Channels: 2
Silence: 0
Samples: 2048
Size: 8192
Sound initialization successful
INFO: Loaded fonts successfully
INFO: Loaded GUI successfully
INFO: Got quit message from GUI. Shutting down...
INFO: Shutting down...
INFO: Exiting
Quote:INFO: Disabling shaders
This means you are stuck with the crappy non shaders mode. Are you getting any stderr output? The game will usually report what went wrong.

Quote:coming from NeedForSpeed shift2 i was disappointed by graphics
I feel with you. You won't believe how much graphics depend on graphics assets. It is not a big deal to draw some highly detailed car meshes with hires textures, but to create them in the first place. VDrift tracks and cars are almost completely conversions from other(rather old) games imho. We've got no professional artists nor can afford one. Our art pipeline might need a review too. Oh well.
No I've only confounded the buttons. They really should be red - green or such.
The AC Cobra looks stunning, needs some finishing only. Maybe smooth or subsurf and chrome reflections. I might have a look at that as I'm familiar with Blender.
Great work, so I only need my CH yoke and pedals to work to leave NFS.
http://www.youtube.com/watch?v=UvVk2JeIpao
Pages: 1 2 3 4 5