Forums

Full Version: bullet-2.73 "cannot find -lbulletcollision" (patch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I checked out most recent svn code and got some problems with compiling.
They are mostly related to the different directory layout and filenames in bullet-2.73.
See the patch for details how I got it to compile here:
http://pastebin.com/f56dc2f6d

Just wanted to let you know.

Werner
What platform, and how did you build bullet? With jam or make?
System: 64bit Linux (Ubuntu Intrepid).
I built bullet with cmake + make

I used cmake because autogen for bullet didn't work properly here:
Code:
running aclocal
running libtool
libtool worked.
running automake
configure.ac:14: installing `./config.guess'
configure.ac:14: installing `./config.sub'
Makefile.am:2: directory should not contain `/'
An error occured, autogen.sh stopping

Werner
That's funny; the windows minigw build fails with the same error. The bullet project has some definite build issues. I'm not sure why they decided to start using autotools recently. Anyway, thanks for the report. Unfortunately building with jam apparently yields different names for the output object files when building with jam (?!?), so let me fiddle with it a bit and see if I can find some way to have scons figure out which object files bullet has generated and use only those. If you have any ideas let me know; I'm not very knowledgeable about scons.
Just a note, I'll keep track of this as issue 115:
http://code.google.com/p/vdrift/issues/detail?id=115
This should be fixed in R2315.
When compiling the bullet libs that accompany R2315, I get the same autogen error as hoehrer.

cmake .
configures fine but what is the exact command for make?

make
requests a target;

make all
claims theres no rule...

Also, you might want to add libtool as a prerequisite on the compiling wiki page - complete newbies like myself might not realise you need it.

Also, the Makefile.am has a tab character after a line of text that stuffs up config.
wesmo Wrote:When compiling the bullet libs that accompany R2315, I get the same autogen error as hoehrer.

Unfortunately, the bullet build scripts are a little screwy, and they seem to be adding new build methods every release, so it's tough to keep track of. I've got a thread open on the bullet forum about it.

Quote:cmake .
configures fine but what is the exact command for make?

Just running "make" right after "cmake ." should work. If you open up the file "Makefile" in a text editor, you should see a note at the top of the file saying it was generated by CMAKE.

If you still can't get it to work, you can try using jam to build bullet.
joevenzon Wrote:I've got a thread open on the bullet forum about it.
That is a link to this thread... Wink
hmmm interesting i was only reading the end of the cmake . output

http://pastebin.com/m7eee749

glut-dev was missing - cmake and make both run fine now!

I've added libtool and freeglut3-dev as dependencies on the compiling wiki page too
thelusiv Wrote:
joevenzon Wrote:I've got a thread open on the bullet forum about it.
That is a link to this thread... Wink

Hahah, whoops. Here's the thread:
http://www.bulletphysics.com/Bullet/phpB...331#p12331
wesmo Wrote:I've added libtool and freeglut3-dev as dependencies on the compiling wiki page too

Thanks!
With the changes in the way Bullet is included are libtool and freeglut still required?
Don't think so... I'll cross those and some others (jam) off the list.
I tried to build subj with cmake. That's what it's show:
Code:
maxx@desktop:~/Downloads/vdrift-2009-02-15/bullet-2.73$ cmake .
-- Check for working CXX compiler: CMAKE_CXX_COMPILER-NOTFOUND
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Check for working CXX compiler: CMAKE_CXX_COMPILER-NOTFOUND -- broken
CMake Error: The C++ compiler "CMAKE_CXX_COMPILER-NOTFOUND" is not able to compile a simple test program.
It fails with the following output:


CMake will not be able to correctly generate this project.
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
-- Configuring done
Ubuntu Hardy 32bit, cmake 2.4-patch 7
P.S. Autotools give the result, posted in 3rd post
Pages: 1 2